Wifi adapter not recognized


It seems that my Wireless adapter Is not working on last alpha 3,
It’s a D-Link Dwa 131. It doesnt light up at all
Is there any command to see if It’s detected ?


lshw or

lshw -C network

Command not found…

Try dmsg.

It’s dmesg

Product : 802.11n WLAN Adapter
Manufacturer : Realtek
SN : 00e04c0000001

I have access to a D-Link DWA-131 Ver B1 and can confirm it doesn’t work in Alpha 3. It looks like the driver is not currently present. Although some additional wireless drivers were added in Alpha 3 there are still a few more yet to add.

Sam - here is the driver that loads in Raspbmc for this adaptor:

Another that appears to be not supported:

Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

The above adapter works with Raspbmc, any plans to support it with OSMC ? Is there a list of supported devices somewhere as I am thinking of buying a Pi 2 and would make sure I pick up a supported WiFi adapter to use with it.

Are you on Alpha4 yet? This should be addressed…

I tried Alpha4 but the result Is the same…

Yes, Alpha 4 here. The blue wifi adapter light comes on but it isn’t getting an IP address. The exact same hardware works fine with Raspbmc.

Same here with this adapter, the blue light is on and does get an iP but it is a wrong one. When I try to ssh into this IP permission is denied and then changes to the right IP and start working . If I reboot the same cycle starts again. Any ideas?

What do you mean by this? Have you set a DHCP reservation?

No I dont have any DHCP reservation but everyone of my 3 pi’s allways connect to the same IP ( different for each one but the same on each Pi) using the same Edimax dongle. What I mean is that when the Pi first connect it has some IP which is no the same that I have been always using and if i try to use this Initial IP nothing works until it changes ri the right IP address?.

This sounds like an issue with your router. OSMC will try and obtain an IP address via DHCP by default unless you have configured a static IP address.

I had similar challenge first time i installed alpha 4… dmesg log didnt show any auth (but show chip was found) even after x times of reboot… until i did total reinstall and then it worked for me… RTL8192CU

Thank you very much for your prompt response Sam, I will check my router. By the way I am so happy with OSMC works great even that its an alpja version. I have Openelec in 2 Pi’s and now OSMC y another and I can tell you that OSMC is a lot faster opening live streams… Thanks for all your amazing work and effort!!!


Problem solved with a simple Router reset…Thanks again Sam

1 Like

Clean install of Alpha 4 and definately no Wifi. Funny you should mention the router issues because that is what you said when I had issues with an early version of Raspbmc, eventually someone changed something in the Raspmc network setup and my problems disappeared. Open Elec works fine, Raspmc works fine, laptops/iPads/mobile phones and printers all work fine with this router (WRT54GL with Tomato Firmware). I’ve assigned a fixed IP address for the Pi too. This all suggests to me that it is an issue with OSMC. If there are any logs I can give you then please let me know as I would like to help you fix issues with your software.

Here’s the thread detailing the problems I had getting it to work with Raspbmc, starts at post #5

As you can see, I have to ensure that I DON’T plug in the ethernet cable when setting up Raspmc - the moment I do that nothing works. Raspian also works fine with this adapter. The only software that currently doesn’t work at all is OSMC and Raspmc has issues that can be worked around during setup. Spot the trend ? Again, if there are any logs I can get for you to help fix this then please let me know.

lsmod reports the following:

Module                  Size  Used by
nfsd                  316820  2 
arc4                    1921  2 
rtl8192cu             101727  0 
rtl_usb                14717  1 rtl8192cu
rtl8192c_common        74148  1 rtl8192cu
rtlwifi               105913  3 rtl_usb,rtl8192c_common,rtl8192cu
mac80211              613006  3 rtl_usb,rtlwifi,rtl8192cu
cfg80211              498098  2 mac80211,rtlwifi
rfkill                 25348  3 cfg80211
uio_pdrv_genirq         3642  0 
uio                     9968  1 uio_pdrv_genirq
fuse                  105798  1 
ipv6                  409953  40