WIFI: After Update, Internet Status Switches from "Busy", "Not Connected", and "Connected"

I am on a Raspberry Pi 1 B+ and just installed the 10.1.20 release. Got everything set up; WIFI, NFS shares, phone app controller, etc. The last thing I did was run “apt-get update” and “apt-get dist-upgrade” which brought me to the 11.1.20 release. After that, my dongle could still see my SSID. I could connect to the SSID, but it would give me a strange IP address that is outside my standard addresses (it was starting with 169.XXX.X.XXX while my router assigns 192.168.X.XXX addresses). So, I set the router to assign the preferred IP to the MAC of the dongle. Now, I get the proper IP address as reported by System Info and my router shows it as connected. However, my internet status goes from “Busy”, to “Not Connected”, to “Connected” change between the 3 frequently. Usually it is listed as “Busy” and I can’t SSH into it nor can I view any folders on the network. My MAC will also sometimes be listed as “Busy”. The short time that it is “connected” it does connect to the internet because I see my weather updated. Again, no problems before the dist-upgrade (which downloaded at great speeds through said dongle). I can’t see it being the dongle as it was preforming without issue prior to the upgrade.

I can’t get logs because I can’t SSH into it. I could wire it to ethernet for debugging, but that means I have to move a monitor to the ethernet spot too which is a hassle. So I could spend some time and effort into debugging this or take that time and start with a fresh install of of the 10.1.20 release. I’ll be gone for a few days and I don’t have the time now to re-install, so I thought I would pose my issue here in case someone has some quick ideas that will get me going before I do a reinstall in a few days.

Which dongle?
Do you have a second SD card to try a clean image?

Sorry for the long absence. This problem isn’t really a huge priority as I have streaming services and a working pi in the living room (issue is the bedroom pi) and I’ve been busy with work.

However, the dongle is an Asus USB-N13. I believe it has a Ralink chip. I’ve been running without my server for several months since moving, but when I tried to do new installs of OSMC, I found that support for realtek had been dropped so my go-to Edimax dongles weren’t working. I fished what dongles I could find out of my box of electronics and found the Asus should work with the Ralink chipset.

Funny enough, after my OP on Christmas Eve, the dongle finally went to “connected” and I SSH’d into the pi. I left the connection running and the SSH was still connected when I woke up 8 hours later. Then I disconnected and left for the few days I said was going to leave for and when I got back, OSMC was still running, but the dongle status was back to “Not Connected”. Again, I haven’t put much time into it. I will eventually restart the device and see if the connection is more stable. As I said in the OP, I won’t do much in terms of debugging because I can just re-install and not update to the 11.20 release. My question was just to see if anyone else had experienced this and if there was a faster solution than re-installing. I’ll restart it soon and if I can get it connected for any length of time, I can upload logs if anyone is really curious as to what my pi is doing.

Have you checked if the connection is actually dropping, and it’s not just Kodi that can’t determine internet connectivity?


Yes. I can’t view any file folders on the network within OSMC and I can’t SSH into unless it says connected. Finally, the Yatse remote app doesn’t work when it says “not connected” or “busy”.

I just restarted the device and the IP address is again given as 169.254.XXX.XX per the OSMC System information. System information is correctly listing the MAC of the dongle. I set my router to assign an IP of 192.168.1.XXX based on the MAC of the dongle. Currently my router does not show the MAC connected.

That’s a link-local address. It means that it couldn’t get an address from DHCP.

It would be interesting to know if setting a static IP address via My OSMC’s Networking settings alleviates the issue


I don’t know if I am setting a static IP address correctly. I select the IP address under My OSMC network settings, enter the IP address I assigned it, click apply and after the fields repopulate, the IP address is back to 169.254.xxx.xx. I have also tried the “Configure Network Using DHCP” but it does not appear to do anything. Reselecting my SSID, I have the option to disconnect or disconnect and forget, so if I’m not connected to my network, it’s weird that it doesn’t have me enter my pass key.

I also selected disconnect and forget. I then selected my SSID, used the IP button to enter the IP before entering my SSID pass key. Still gives me 169.254.x.x and no gateway is listed.

Last one until you respond. I took my Tenda dongle out of my living room pi, put it in this trouble pi and I was able to connect to the network without issue. I don’t know if this tells us anything since they use different chipsets, but it is weird that the pi did connect sometimes with the ASUS dongle and now it won’t pull a proper IP address.

Also, once given the link-local address, I go to Network info under System inf and MAC is listed as “Busy” and so is internet. If I recall when this happened on Christmas eve, the IP address rectified itself after some amount of up time. I’ll leave it running and see if it changes.

I rebooted my router while watching my network information. As it went down, the link-local ip went away. Once it came back up, OSMC was back to having a link-local address.

A couple hours later and I have an IP from router. I have normal network connection for now. I’ve done nothing but wait.