WiFi connection issue

After installing an osmc on my Raspberry Pi 4 with wireless network option I can see the available wireless networks in my surroundings on the list on right side in network seytup section of My OSMC. I can see also my own network (SSID) there.

If I try to connect to the network (click on SSID) and next click on YES I fails with a message: OSMC Network Setup Unhandled Exception caught - See log for detail

Could you advice please how to fix this?
Thanks in advance


Which version of OSMC did you install on your device?


Hi, I tried to install the latest but the link to image was broken at that time. So I installed 2022.10-1 directly from the osmc-installer.

Let me say that I noticed some progress. I tried to connect on another place to some other WiFi network and surprisingly it worked. After I connected to it I updated system at all. And after return I connected to my network also with no further issue.

It means my WiFi connection problem has been solved.

Thanks for your will to help me.

I’ve checked Download - OSMC – but the links seem OK there.

Great – we didn’t change anything WiFi related in this release however.