Wifi Dongle looses connection after 3-4 days and does not reconnect automatically


after some help from the forum, I managed to run the OSMC wifi Dongle on MY RPI1 on 5GHz Network just fine.

I run my RP1 24/7 and it works flawlessly, but after 3 or 4 days of running without issues, the Dongle looses connection but does not reconnect to the wifi network.

I always have to pull power and make the rpi reboot to get Wifi again, and then it will work again for 3 to 4 days.

Does this problem sound familiar? Any way to avoid having to reboot after 3-4 days?

Haven’t heard of this one. Is the Pi responsive when this happens?
If so – some logs may give some clues.

What does My OSMC -> Network show?
It sounds like a potential DHCP lease expiry that isn’t being renewed.


My other devices on the net do not have such problems, but they don’t run 24/7. And if they run, I dont have any issues.

I also don’t have any IP lease time restrictions set in my router.

The RPI seems responsive and fine except for no Wifi, unfortunately I run it headless and control it via App, and if the wifi is gone, I can not config it without any hassle, so I just pull the plug on the rpi.

Also this happens only after 3-4 days running so its hard to reproduce. maybe the logs can give a hint.

Here are the logs: http://paste.osmc.tv/dujiqatuta

Try setting a static IP if you can. It would be interesting to know if that helps.
If you are able, after loss of connectivity, try attaching an Ethernet cable and running the log uploader.


Please check out this thread and see if it helps.

Static IP kinda worked. Now I only lost connection after 2 weeks. And had to pull the plug then. Since Mid December I had only to pull it once. However the raspi still does not reconnect automatically after it looses connection by itself.

Did you try to address the group rekeying issue?

No id di not because my router AVm 7390 does not have any setting to change the group key interval.

Also the post tells you to change the interval to 24 hours, but my connection remains stable for much longer than only 24 hours.

Your log is being spammed every 10 minutes with the group rekeying message. It’s not clear that this is the root cause of your problem but reducing the number of such rekeying events to, say, once every 24 hours might have helped. My own feeling is that the problem probably lies with the router.