WiFi dongle not recognized

I have a WiFi dongle which uses the mt7601u driver, which is available on Kernel 4.2. I’m using the version 2015.09-2 of OSMC on a Raspberry PI Model B.
When I run ifconfig, there’s nothing on wlan0.

Do I need to compile the driver? I thought that it was already included in the latest version.

I’m really confused. The August changelog says “Added support for the MT6701U wireless dongle”, but I guess the Kernel support is missing.


It should be working OK. What does dmesg say?

[   18.322247] usb 1-1.2: reset high-speed USB device number 4 using dwc_otg
[   18.432400] mt7601u 1-1.2:1.0: ASIC revision: 76010001 MAC revision: 76010500
[   18.463898] mt7601u 1-1.2:1.0: Invalid firmware image
[   18.464558] mt7601u: probe of 1-1.2:1.0 failed with error -2
[   18.464731] usbcore: registered new interface driver mt7601u


Doesn’t like the firmware by the looks of it. That’s odd, because I’ve had some users report that it’s fine


Indeed. I’ve tested Raspbian Jessie a few days ago and the dongle worked like a charm.

Solved! Installed a fresh image again and everything is working. Thanks for your awesome work!