Wifi drop outs

#1

I’ve had my Vero 4k for a couple of weeks now and I’m noticing that it keeps disconnecting from my wifi. I’ve tried connecting it to both 2.4ghz and 5ghz and the same thing happens.

It reconnects on its own, but it means that I need to restart the openvpn service to get it back online.

Here’s what I see from dmesg:

[71967.970942] wl_iw_event: Link Down with BSSID=10:13:31:57:CE:DB
[71967.971021] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK
[71967.971032] link down if wlan0 may call cfg80211_disconnected. event : 16, reason=1 from 10:13:31:57:ce:db
[71967.972004] wl_iw_event: Link Down with BSSID=10:13:31:57:CE:DB
[71967.972039] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK
[71967.975650] cfg80211: Calling CRDA for country: AU
[71971.842951] Connectting with 10:13:31:57:ce:db channel (1) ssid "dinosaur_party", len (14)
[71971.896523] wl_iw_event: Link UP with BSSID=10:13:31:57:CE:DB
[71971.896549] wl_bss_connect_done succeeded with 10:13:31:57:ce:db
[71972.036628] wl_bss_connect_done succeeded with 10:13:31:57:ce:db

I never had these issues on my R-Pi 2 with an Edimax EW-7811Un N150 Wireless USB Adapter Nano.

Any tips?

I searched here and couldn’t find anyone else reporting issues, so I’m a bit baffled.

I’m tempted to disable the onboard wifi and use the N150 again…

Connman shut down when transmission is operating
#2

What’s the DHCP lease time? Does setting a static IP resolve this?
Do you experience the problem with OpenVPN disabled?

Full logs will probably be more insightful.

Sam

#3

When I first noticed this problem I switched from using DHCP to having a static IP assigned and manually configured on the vero, the problem still occurred.

Even with the openvpn service disabled it is still dropping and then reconnecting to the wifi at seemingly random times.

Below is all the log lines regarding the two drop and reconnects that have happened since my last reboot:

#1

[63888.428482] wl_iw_event: Link Down with BSSID=10:13:31:57:CE:DB
[63888.428565] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK
[63888.428575] link down if wlan0 may call cfg80211_disconnected. event : 16, reason=1 from 10:13:31:57:ce:db
[63888.429852] wl_iw_event: Link Down with BSSID=10:13:31:57:CE:DB
[63888.429977] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK
[63888.431938] cfg80211: Calling CRDA to update world regulatory domain
[63888.433073] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[63892.295809] Connectting with 10:13:31:57:ce:db channel (1) ssid "dinosaur_party", len (14)

[63892.351375] wl_iw_event: Link UP with BSSID=10:13:31:57:CE:DB
[63892.351404] wl_bss_connect_done succeeded with 10:13:31:57:ce:db
[63892.363305] wl_bss_connect_done succeeded with 10:13:31:57:ce:db
[65374.722295] wl_iw_event: Link UP with BSSID=10:13:31:57:CE:DB
[65374.722333] wl_bss_connect_done succeeded with 10:13:31:57:ce:db
[65374.804620] wl_bss_roaming_done succeeded to 10:13:31:57:ce:db
[65384.806740] CFG80211-ERROR) wl_cfg80211_disconnect : Reason 3
[65384.809770] wl_iw_event: Link Down with BSSID=10:13:31:57:CE:DB
[65384.809860] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK
[65384.809917] link down if wlan0 may call cfg80211_disconnected. event : 16, reason=2 from 10:13:31:57:ce:db
[65384.878996] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_DEAUTH
[65388.693957] Connectting with 10:13:31:57:ce:db channel (1) ssid "dinosaur_party", len (14)

[65388.736872] wl_iw_event: Link UP with BSSID=10:13:31:57:CE:DB
[65388.736896] wl_bss_connect_done succeeded with 10:13:31:57:ce:db
[65388.933876] wl_bss_connect_done succeeded with 10:13:31:57:ce:db

#2

[74994.420567] wl_iw_event: Link Down with BSSID=10:13:31:57:CE:DB
[74994.420620] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK
[74994.420631] link down if wlan0 may call cfg80211_disconnected. event : 16, reason=1 from 10:13:31:57:ce:db
[74994.421615] wl_iw_event: Link Down with BSSID=10:13:31:57:CE:DB
[74994.421671] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK
[74994.423328] cfg80211: Calling CRDA to update world regulatory domain
[74998.280849] Connectting with 10:13:31:57:ce:db channel (1) ssid "dinosaur_party", len (14)

[74998.358527] wl_iw_event: Link UP with BSSID=10:13:31:57:CE:DB
[74998.358598] wl_bss_connect_done succeeded with 10:13:31:57:ce:db
[74998.416979] wl_bss_connect_done succeeded with 10:13:31:57:ce:db

And just on the off chance there is anything else helpful, here is the entire log: https://pastebin.com/LRUfZwuV

#4

First, whenever possible, please post a full log using grab-logs -A.

One possibility that hasn’t been mentioned is that wifi power management might be switched on. This has been known to cause instability in the past and I thought had been switched off by default, though my Pi 3 shows it is still on. You can check its status with iwconfig wlan0. To switch it off, run sudo iwconfig wlan0 power off .

#5

Power management should be off my default in OSMC.

But with newer (not yet released) Broadcom firmwares I don’t think this will be possible; and iwconfig may stop allowing this to be toggled.

#6

WiFi is very environmental, so it can be hard to nail down some of these issues. Have you any other devices in the room; how are they doing?

Have you tried connecting Vero 4K to a 2.4Ghz network and seeing if it behaves better?

Sam

#7

Also my understanding and this is a Vero 4K. But…

Pi 3:

wlan0     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

Vero 4K:

wlan0     IEEE 802.11  Access Point: Not-Associated   
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  invalid crypt:0  invalid misc:0

So, as I mentioned above, although this thread is about the Vero 4K, my Pi 3 is showing that power management is on by default, in spite of the conventional wisdom being that it is now disabled by default on OSMC. (I can’t imagine I’ve set it to be on myself in a way that survives reboots.) Perhaps it’s also on in the 4K, even though the output of iwconfig doesn’t mention power management at all.

One thing, I didn’t do, is try the sudo iwconfig wlan0 power off command on the Vero. It doesn’t work (apologies):

osmc@osmc:~$ sudo iwconfig wlan0 power off
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Bad address.

Bottom line: On my Pi 3, power management seems to be on by default. Its status on the Vero 4K cannot be determined and/or changed using iwconfig.

#8

Here’s the URL from the grab-logs cmd https://paste.osmc.tv/tujufatefe

I have tried both 5ghz and 2.4ghz with the same issues.

I never had these problems running an rpi2 with osmc on it connecting to the same AP via an Edimax EW-7811Un N150 Wireless USB Adapter Nanos.

I had tried the ‘sudo iwconfig wlan0 power off’ cmd and also received that error.

#9

It’s off in kernel. Userland doesn’t know about this.

So toggling won’t do anything

#10

As Sam has said, WiFi is very sensitive to the environment. While the Vero 4K has an internal antenna, it should be better than that found on a nano dongle, though that might make it more efficient at picking up RF interference from a nearby microwave oven.

I can’t offer any straightforward answer but here are a few things that come to mind:

  1. There is a setting on your router that is causing group rekeying to be performed every 600 seconds. Try to find it - it will probably be called something like “Group Key Update Period” - and set it to the maximum allowed value. It’s a bit of a log shot that it will eliminate the disconnections but it’s something that needs to be changed anyway…

  2. Ensure that the router is on a fixed channel. On 2.4GHz only use channels 1, 6 or 11.

  3. Install CRDA with sudo apt-get install crda . Then set it to the relevant country with sudo iw reg set <country-code>. A list of country codes can be found in /usr/share/zoneinfo/zone.tab. Also edit file /etc/default/crda and add the relevant country code after REGDOMAIN=.

  4. Make sure transmission is not running (as well as openvpn).

  5. Another long shot but ensure that WiFi is using WPA2/PSK.

Intermittent Buffering over network