WIFI Dropping Constsitently with OSMC and RPi3

As you are using NOOBS does the wifi work stable on the other OS?

The logs show many disconnects and rekeying. Really suggest to check signal strength with Wavemon.

To be honest, I never run any other OSs. Its connected to my TV purely as a media center.

Not really sure which metric to key on with Wavemon output, but

link quality73-77%
signal level -56-59dBm

Then I suggest next time you do a reinstall you go for a plain OSMC install instead of NOOBS

Does it stay that way? You can see graph with F2.
Not the highest values but also not a reason for rekeying.

I can certainly do a straight OSMC install next time. I’m trying to clean my library so it reloads better. Will make recovery much easier.

Any other ideas on rekeying? Could it be my router?

I have similar issues with a new osmc installation:

Log:
http://paste.osmc.io/sudehukado

Speed drops under 15Mbit/s in local network. There seems to be a problem with the wifi driver. This also happsn with an external usb device…

I found this: Group rekeying…

will try when back in front of router

My intervall is 3600

I seem to have the same issues the OP is having.

I’ve updated to the OSMC December 2016 version yesterday, since then I have seen already multiple times that Kodi/OSMC/rPi3 is not connected to my WiFi network anymore. Since that is the only way to interact with it (using Yatse) I left the system page open so it displays the wifi network data (i.e. IP address). Checked my router and indeed when Yatse says the device is offline, the rPi entry (static IP address configured) is not in the client list anymore even though the pi seems to be convinced it still is connected to the wifi.

Please note that I have never in the 1+ year of using OSMC experienced these dropouts, the only way to restore the connection is by pulling out the USB power and plugging it back in (I do not have any USB keyboards laying around).

Could this be a bug introduced in any of the OSMC versions after October 2016? Up to yesterday I was using that version and the wifi worked fine without any issues.

Is there any debug logging I can report to figure out what is causing this?

I can confirm that this was the same MO for me. Was fine prior to November update.

There have been no changes to WiFi (ConnMan and kernel) in the last update of OSMC.

If you believe that there are issues with the December version, it would be interesting if someone could download the November version and compare. Then we may have some clues.

Hey Sam

Is there a way to roll back to an earlier version or do you mean to install the oct/nov version of OSMC from scratch?

Any way I could do this without losing any data/prefs?

I’d like to add to my previous post that the wifi stops working fairly quickly, sometimes after a couple of minutes (let’s say 5) and sometimes it seems a little longer. I also suspect that that timing might depend on the traffic over the interface, not interacting will keep it alive longer than downloading a file (e.g. through Yatse’s offline media function).

Thanks

Yes you would need to take an older image from the Download page and install that.
Suggest to do that on a second SD card then you don’t have to worry about your current installation and data.

Alright, I’ll try first with the October release again to see if that one keeps its connection.

First of all though I’m going to try with an external wifi dongle I have laying around (that cheap popular one from DealExtreme). See if using another interface has any effect. Any special things I would have to do to make it work with the external wifi dongle rather than the pi3’s internal chip?

Hi Sam

Was going through the changelog of OSMC and found the following for the December/Xmas update

Improved WiFi performance by reducing background scanning under certain environmental conditions

Could this have any impact here?

See below

I got myself a USB keyboard to check out locally what is going on. What I see is that in the OSMC app the wifi scanning stops working, no other networks are shown.

The connected wifi is still there (at this point OSMC/Kodi still believes it is connected) but it is not functioning. When disconnecting the network it disappears (not selecting forget obviously). No SSIDs appear in the list anymore.
Disabling and enabling the wireless interface and still no SSIDs are found. It does seem like a WiFi driver issue to me. Is there any logs I can access from within Kodi?

Googling a bit, this seems interesting as well: wlan freezes in raspberry pi 3/PiZeroW (Not 3B+) · Issue #1342 · raspberrypi/linux · GitHub

Without logs to accompany the symptoms you are reporting at any given time, your report is pretty useless… Also, power management is already off in OSMC by default.

Fair enough, if it happens again I will post the logs here. So far for some reason it seems to work fine this evening after rebooting the Pi.

Thanks… It’s just nearly impossible to provide any relevant support without relevant data points to compare against other users with similar issues and to check for proper configuration or other use case conditions.