WiFi vs Wired Performance - huge difference

In fairness to stream internally on my network in SMB in full HD only takes about 5-6Mbs, here I’m talking about such a dramatic difference that it led me to think that something else was afoot. Either that the internal WiFi is poorly implemented either at hardware or driver level or a configuration issue in OSMC.




Thank you, I realised after I posted that I should really find out myself!

Very stranger results using speedtest.py

Wired I’m only able to run without flags, if not it will not find the configuration. In wireless I have to run:

./speedtest.py --secure

Wired if I run this command speedtest won’t work, so just ./speedtest.py

Wired: 27dn 12up
Wireless: 0.54dn 6up

Quite a substantial difference.

What case are you using? If it’s metallic or shielded it will most likely cause poor wireless performance with the Pi inbuilt wireless as the antenna will be shielded

I also have strange wifi issues. I also used an external usb wifi antenna and deactivated the internal antenna but the results are the same. I just get 9-15/Mbit/s (to my local NAS and to the Internet). The distance between router and Pi does not play a role ( I moved the Pi to the router -> same result)
I also have video stuttering issues which could be connected to my wifi issues.

Ping to NAS:

— ping statistics —
27 packets transmitted, 27 packets received, 0% packet loss
round-trip min/avg/max = 1.585/4.837/7.999 ms

<img src="/uploads/default/original/2X/6/660e890ec504a68a33b25fda259d9b86bfce637c.png" width="668"height=“419”>

root@osmcwohn:~# uname -a
Linux osmcwohn 4.4.27-5-osmc #1 SMP PREEMPT Tue Nov 22 02:23:12 UTC 2016 armv7l GNU/Linux

Maybe it has to do with the AP’s security protocol, I will try again tonight with an Open AP and see it there are problems. The thing that worries me is why can I only run in “secure” mode over WiFi.

Are you talking about WPA2?

This is my log:

You need to upload a debug log.
You should also run an iperf test if possible.
You should avoid using hostnames in your shares and you should try an fstab based mount for the best SMB performance.
You may have an environmental issue (crowded 2.4Ghz channels)

You say you tried another USB dongle, but you don’t say what model it was. I closed your GitHub issue as the information provided is not sufficient to prove that there is a bug.

I also mounted the shares via fstab and had the same issues. I use the IP and not hostnames.
And no I do not have crowded 2,4Ghz channel.

Debug Log:


I am the only one who is using channel 8:

The external Antenna:
TP-Link TL-WN722N (Atheros AR9002U)

Please stick to one thread. I just found five threads with posts from you and it’s very hard to keep track of what you have and haven’t tried.

GetMovieId (smb://NAS12TB/Videos/Spielfilme/Ben Hur/d-benhur-1080p.mkv

Shows that you are still using Kodi’s built-in SMB client and hostnames.

It is still unclear which WiFi adapter you are using. Some people have said that the Pi’s internal antenna is a bit weak, but realistically, it is probably compounded by 2.4Ghz overcrowding. An optimal real world performance speed would be 35-40Mbps for a 1x1 (tx/rx) antenna.


At the moment I am using the internal antenna. The debug log did not use the shares from fstab.
I copied files from the mounted shared and checked the performance with iftop.

The only thing I could really suggest would be to use speedtest-cli if you are unfamiliar with iperf (this will vary a bit however).

You can run it on OSMC and you could put the dongle in a computer, in the same position in the house and go to speedtest.net and compare the results.

SMB has protocol overhead. You won’t get the full speed. There are also other factors, like whether you are using SMBv2, SMB authentication and things like HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters on Windows systems.

If you want to get better throughput, you will benefit from NFS, but I cannot say that this will resolve the issue. If you don’t have enough bandwidth, it won’t work miracles but it may give you a little more headroom.

Also make sure when you tested the external dongle that you disabled the internal one in /boot/configt.txt.

I disabled the internal one :slight_smile:
I just tested iperf:

root@osmcwohn:~# iperf3 -c -p 5201
Connecting to host, port 5201
[  4] local port 55280 connected to port 5201
[ ID] Interval           Transfer     Bandwidth       Retr  Cwnd
[  4]   0.00-1.00   sec  3.84 MBytes  32.2 Mbits/sec    0   97.6 KBytes
[  4]   1.00-2.00   sec  3.58 MBytes  30.1 Mbits/sec    0    102 KBytes
[  4]   2.00-3.00   sec  4.23 MBytes  35.5 Mbits/sec    0    115 KBytes
[  4]   3.00-4.00   sec  4.12 MBytes  34.6 Mbits/sec    0    120 KBytes
[  4]   4.00-5.00   sec  4.02 MBytes  33.7 Mbits/sec    0    127 KBytes
[  4]   5.00-6.00   sec  4.15 MBytes  34.8 Mbits/sec    0    127 KBytes
[  4]   6.00-7.00   sec  4.14 MBytes  34.7 Mbits/sec    0    127 KBytes
[  4]   7.00-8.00   sec  3.91 MBytes  32.8 Mbits/sec    0    127 KBytes
[  4]   8.00-9.00   sec  3.97 MBytes  33.3 Mbits/sec    0    127 KBytes
[  4]   9.00-10.00  sec  4.08 MBytes  34.2 Mbits/sec    0    127 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec  40.0 MBytes  33.6 Mbits/sec    0             sender
[  4]   0.00-10.00  sec  39.8 MBytes  33.4 Mbits/sec                  receiver

iperf Done.

Looks much faster.

This looks correct for single band 802.11n in a reasonably clear environment. This is pretty much the best you’ll get for 802.11n

What would be fine but its just iperf which gets this performance.
Wget gets this:

root@osmcwohn:~# wget http://mirror.global-layer.com/speedtest/100mb.bin
converted ‘http://mirror.global-layer.com/speedtest/100mb.bin’ (ANSI_X3.4-1968) -> ‘http://mirror.global-layer.com/speedtest/100mb.bin’ (UTF-8)
–2017-01-09 17:26:12-- http://mirror.global-layer.com/speedtest/100mb.bin
Resolving mirror.global-layer.com (mirror.global-layer.com)…, 2a00:1678:0:2003::1337
Connecting to mirror.global-layer.com (mirror.global-layer.com)||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 100000000 (95M) [application/octet-stream]
Saving to: ‘100mb.bin.1’

100mb.bin.1 2%[ ] 2.13M 193KB/s eta 5m 13s

I just mounted the sahres via fstab AND IP Adress and started copying a file:

Still slow.
Its really strange, only iperf gets full speed in my network, every other applicatin (smb / wget) seems to be slow.