Wifi Drops outs on Rasp Pi 2 B with RC

Hi. See my related post. WiFi (very strange) Issue - RC

Thx

Same issue here with a Raspberry Pi 2 and Edimax EW-7811UN WiFi adapter.

Hi, Same issue on a Pi2 with a Dlink DWA-121 802.11n Wireless N 150 Pico Adapter [Realtek RTL8188CUS].

It’s almost unusable, i’m forced to go back to alpha 4 =/

almost unusable lol no its unusable unless you plan to use it without wifi rc version is less stable than the alpha version ? going back to raspbmc here until the final version is sorted and the creases are ironed out I know its slower but at least it does what you want it to not even video will stay on for longer than a minute pi just totally freezes doesn’t happen on alpha 4 or raspbmc so theres problems there somewhere :open_mouth:

Maby a developer can give us information if this is goining to be fixed in final version 1.0? Have you found out what the problem is?

Hi,

Would you know if a fix is likely to come soon?
Just to know if re-installing an older version is my only option… =/

Thanks

Well, for me, sometimes it works for 30mn, so i can watch a short episode before having to do a hard reset =)
And yes it was working really fine on alpha 4 with a Pi 2
I also miss the small fonts… the one on the RC are really huge!

I personally went back to Alpha 4, it’s much more stable from all points of view.

We’re well aware of wireless driver issues in the RC and are working on getting them resolved. (If it was easy, it would have been done already, unfortunately it is anything but easy as wireless driver support in Linux is a bit of a minefield especially in the latest kernels)

However I think it’s unfair to say that Alpha 4 is “much more stable from all points of view” - looking at it from an inside perspective I can assure you that there are a LOT of problems with Alpha 4 that are resolved in the RC. I personally don’t agree that Alpha 4 is more stable, especially after having worked hard to fix so many problems present in Alpha 4.

If you have real problems with the RC aside from wireless then we need to know about them - giving up and going back to Alpha 4 does not help anyone - you will be stuck on Alpha 4 forever, (which is now orphaned and will never receive any updates) and any problems with the RC that you are seeing may not get resolved.

Don’t assume that because you see a problem that the problem is obvious and that everyone else (including the devs) see it. To get issues resolved moving forward people need to help test the RC, report the problems they find, be willing to test and provide logs when asked and so on.

We want to get the final release completed but if everyone just runs back to Alpha 4 because its “easier” then we will never get a good solid final release.

I’m sorry if I sounded dismissive. I know you guys are hard at work and my attitude does not help.
And I know what goes in to making a great product, and know that you guys are doing the best you can in doing it.

Now, maybe a little backstory will get you to understand my point of view. Me and my SO spend 10, 11 hours per day at work. I being a software dev, she being a HR consultant, have really busy lives. The only time we get to spend together, as you can imagine, is a couple of hours at the end of the day, when we watch something like friends or Seinfeld, and so on. For those two hours, I literally can’t afford to investigate problems, or search for workarounds, or verify and upload logs. We just can’t.

Also, this weekend is my first weekend free, without school, without deaths in the family, without parents in law visiting, etcetera. Based on this, I was planning on buying a second microsd on which to install the RC, without disrupting the current stable (for me) Alpha 4, and seeing how I can help out.

And my initial affirmation

was based on the fact, that I had huge freezing issues on RC, but no one else was mentioning them over here, so I didn’t want to start complaining for a issue, I probably was the only one to have. Was planning on going back at a later time (this weekend) to see if they persist, and if larger affecting problems (the wifi) have been fixed, so I can report my problem which is puny in comparison.

/rant

1 Like

Any update on this devs?

Please update to RC2 and let us know if this issue persists.

Updated using built in updates module from OSMC settings and a LAN connection. I then disconnected the LAN connection and tried the wifi but it fails to connect to my WiFi. Light on dongle in now blinking (wasn’t on RC1). Rebooted the device but same thing.

I’ve uploaded the log to http://paste.osmc.io/efujecumey.

@Kieffer87

This thread has had a few too many replies for me to really keep track of

I’d suggest those still experiencing WiFi issues with RC2 start a new thread with the dmesg output, their dongle name and the symptoms they’re experiencing

S

So I just pulled the plug on my LAN connection again but left Wired enabled in OSMC settings. I then selected my WiFi and it connected but didn’t ask for my Wifi password. I then tried to recreate what I just did without any success. To get wifi to connect again I had to disconnect the LAN (leave adapter enabled). Close the network settings, go back into network settings and then connect to my Wifi.

Log file: http://paste.osmc.io/atideqalic

Are you saying Wifi did not automatically connect while you had Ethernet connected, but that once you unplugged Ethernet Wifi did automatically connect ?

If so this is the expected behaviour. Even with SingleConnectedTechnology=false in /etc/connman.conf (a change we made recently) because Ethernet has higher priority than Wifi (PreferedTechnologies=ethernet,wifi in /etc/connman.conf) if you already have Ethernet plugged in (the higher priority device) it will not bother to auto connect the lower priority device.

You can still manually initiate a connection to wifi and they will both stay connected (until reboot) but it will only auto connect to wifi if Ethernet is unplugged. See the following connman documentation for an explanation: (Autoconnecting section)

https://01.org/connman/documentation

Thanks! I guess It works now… Been up 2hours and stable connection. :relaxed:

Hello,
I want to add my problem in this topic, because it looks like similar, but with small differences:

Hardware
Raspberry 2
WiFI: Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

As power i Have 2.1amper adapter.

Case
After connection to WLAN after few second/min i lost connection but only with internet internal network f.e. ssh still working, I can ping/telnet other computers in network.
To restore connection with internet I must restart router.

logs/others
WiFi connection is in good condition:

  1. wavemon shows 96+% as link quality and 18dBm singal.
  2. log dump on my google drive https://drive.google.com/open?id=0B51URSTcqlXJR3Y0OWx1WUhoOTg

Your log is in a completely unreadable form, as well as being a download rather than a paste log. Please capture a proper log of the system journal like so, after reproducing the problem:

sudo journalctl | paste-log

By the way, the RTL8188CUS driver is currently problematic - there have been a number of reports of problems with adaptors using this driver.

O man, I have tried searching this issue for the last 6 months, finally found people with the same issue.

However, I see that the thread is more than a year old. Has this issue been resolved?
I am still experiencing drop outs, it looks very similar to what is said in here, however i also use a vpn and I have not managed to completely single out the problem.

Strange thing is, a couple of months ago I had no problem

rpi2 + TL-WN823N + latest osmc