Wifi failed to connect raspberry pi 4

Hi. I’m trying to connect to wifi using the built-in pi4b wifi adapter but it didn’t work. The error simply state “failed to connect”. The problem is similar to these threads, and I’ve tried the steps without any success :

Connmanctl commands output error after typing in passphrase :

Agent ReportError wifi_superlongwifistring_managed_psk
Agent request cancelled by ConnMan
Error /etc/connman/service/wifi_superlongwifistring_managed_psk : Operation aborted

Also there are unhandled exception errors popping out trying to connect from the GUI

I had to bring the system to my router and connect using ethernet so that I could post the log here : https://paste.osmc.tv/otewulumig

Can you show us the exact commands you have tried to run?

connmanctl> scan wifi
connmanctl> services
connmanctl> agent on
connmanctl> connect wifi_xxxxxx_managed_psk
connmanctl> [passphrase? mywifipassword

After that, the tty shows error like I showed on my first post

What region are you in?

Is it a standard WPA(x)-PSK network?

South East Asian region, and yes I believe this is a standard WPA-PSK network.

Either Raspberry Pi OS and DietPi (based on Debian Bullseye) has no problem connecting to the same wifi.

dmesg output during a connection attempt may provide some clues.

Here is the full dmesg log : https://paste.osmc.tv/raw/fodolafame

Parts of output that might be relevant :

[Wed Sep 29 16:32:46 2021] brcmfmac: F1 signature read @0x18000000=0x15264345
[Wed Sep 29 16:32:46 2021] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[Wed Sep 29 16:32:46 2021] usbcore: registered new interface driver brcmfmac
[Wed Sep 29 16:32:46 2021] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt failed with error -2
[Wed Sep 29 16:32:46 2021] bcmgenet fd580000.ethernet: configuring instance for external RGMII (RX delay)
[Wed Sep 29 16:32:46 2021] bcmgenet fd580000.ethernet eth0: Link is Down
[Wed Sep 29 16:32:46 2021] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[Wed Sep 29 16:32:46 2021] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar 23 2020 02:19:54 version 7.45.206 (r725000 CY) FWID 01-88ee44ea
[Wed Sep 29 16:32:47 2021] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled

Nothing obvious in those logs to me unfortunately.

You could try creating a personal hotspot on your phone and seeing if you could connect to that.

I had similar issue w RPi3B+ in US with fresh install. Ended up installing v18 and updating which worked

Just to update, even with new fresh install, I haven’t been able to solve the issue. Unfortunately there’s only one image version for rpi4 that can be tested.

I ended up using LibreELEC, and i was able to connect to the same wifi. There’s some caveat, the wifi doesn’t connect automatically after reboot/shutdown, but that’s nothing major.

I’m not sure what’s the difference between LibreELEC and OSMC in terms of which version of kernels or firmwares that were used, but I’ll wait for further major updates before trying to use it again.

Output of dmesg on LibreELEC vs OSMC would be interesting.


Have you tried to select wired during the image creation?
This was the only thing that would allow me to connect to wifi.

Think I have a same issue…

Raspberry Pi4 4GB
Installed OSMC using the Windows tool onto a 32GB micro SD

During the install it asked for my SSID and Password (no way to skip past this??), so I entered.
After configuring language, region and location i checked wifi using ‘My OSMC’, it wasn’t connected.
I then tried to connect both my networks and its failing with “Unhandled Exeption…”

You can select configure networking later.

I’ve started again and selected ‘Wired Connection’. I could not see an option for configuring later, I must be missing something obvious…

All good now, working

You don’t have to pick an option.