Wifi issue

My OSMC is updated to last version and still can’t spot my wifi network

Did you change the world regulatory domain? Some logs should confirm this.

@sam_nazarko

what’s “world regulatory domain”?

how do I change it?

I assume that @sam_nazarko was refering to the latest version that was in testing and released in stable last night.

That’s correct.

I just updated to latest version and wifi is not spotted yet.
I also did sudo rm-rf /var/lib/connman/wifi* but issue was not solved.

Now when I go on connmanctl and I type scan wifi I get

Error /net/connman/technology/wifi: No carrier

Did you try enable wifi first?

Can you upload some logs via Ethernet?

enable wifi done. Still not working.
Now my wired connection is having issues too. After few seconds OSMC loses connections to ethernet

Here’s my log https://paste.osmc.tv/oyidafugix.xml

CRDA and Kodi region matches or is None.

I think you need to pick a region.

On Settings → Interface → Regional → Language
Language = none

I choosed a region and after reboot is still not spotting my wifi.
Do I need to select regione from somewhere else?

This is not related to the setting that has been suggested.

You need to set the world regulatory domain via My OSMC.

how do I set world regulatory domain on my osmc?

This should be an option in My OSMC → Networking.

Sam