Wifi issue

I’m trying to connect to my wifi unsuccessully.
Usually I solved on command line using connmanctl.

Now connmanctl is not helping at all. After I tap connmanctl I get the following log:

Error getting VPN connections: Rejected send message, 2 matched rules; type=“met hod_call”, sender=":1.36" (uid=1000 pid=1142 comm=“connmanctl “) interface=“net. connman.vpn.Manager” member=“GetConnections” error name=”(unset)” requested_repl

Into connmanctl menu I type:

scan wifi
services

and I see some wifi networks, but not mine.

Can you please help me?

Can you please upload some logs (perhaps attach an Ethernet cable temporarily) so we can ascertain what version of OSMC and the device you are using?

Sam

I’m using a Vero 4K+ and I have OSMC Kodi 18.9 and OSMC November 2020 2020.11-1

This version is very old and is no longer supported.

I understand.

Anyway shouldn’t connmanctl scan my wifi regardless of the OSMC version?

It should, but that VPN isn’t the cause of your problem and without full logs (not sure if you can establish an Ethernet cable), it’s hard to speculate.

I would either reinstall or try attach an Ethernet cable and update.

1 Like

@sam_nazarko I finally was able to upload a log.

you can find it here https://paste.osmc.tv/abalucivih

I started reading it and I found:

Sep 12 20:26:31 osmc systemd[1]: Starting OpenVPN service…

Is OpenVPN installed on default? I don’t remember I ever installed it

Yes - for some time, to facilitate an easier use of OpenVPN.

I’m not sure what you mean.

Why is OpenVPN installed? What’s its job on OSMC?

As explained above its job is to facilitate OpenVPN usage and reduce need for apt usage to introduce this functionality, so VPN addons just work

Got it.

Anyway can you see anything that could cause the wifi issue on the log i posted?

HI,

Please try the following, on the commandline issue:

sudo rm-rf /var/lib/connman/wifi*

Then reboot. Hopefully your wifi connection show now be visiable and you should be able to connect.

Thanks Tom.

just done.
OSMC doesn’t spot my wifi yet.
I tried both OSMC GUI and connmanctl.

Hi,

This maybe the problem:

Start-Date: 2022-09-05  00:00:44
Commandline: /usr/bin/apt-get-real install connman
Requested-By: osmc (1000)
Install: connman:armhf (1.36-2.1~deb10u2)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2022-09-05  00:00:45

Start-Date: 2022-09-12  20:18:48
Commandline: /usr/bin/apt-get-real install connman
Requested-By: osmc (1000)
Install: connman:armhf (1.36-2.1~deb10u2)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2022-09-12  20:18:49

osmc packages it’s own version of connman. Can you please issue:

sudo apt-get update && sudo apt-get dist-upgrade

And provide the output.

Thanks Tom.

After a long sequence of “preparing, unpacking, setting up” I get this:

Done
Setting up avahi-daemon (0.7-4+deb10u1) ...
Removing obsolete conffile /etc/network/if-up.d/avahi-daemon ...
Removing obsolete conffile /etc/resolvconf/update-libc.d/avahi-daemon ...
Setting up vero3-mediacenter-osmc (19.4.0-1) ...
Setting up vero3-device-osmc (1.5.0) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for libc-bin (2.28-110.4) ...
Processing triggers for libgdk-pixbuf2.0-0:armhf (2.38.1+dfsg-1) ...
Processing triggers for ntp (1:4.2.8p12+dfsg-4) ...
Processing triggers for dbus (1.12.20-0+deb10u1) ...
Processing triggers for mime-support (3.62) ...
Processing triggers for ca-certificates (20200601~deb10u2) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.

Now I have a new version of Kodi, wifi Is still not spotted and I lost my customizations.
Anyway my wifi is still not spotted

Hi,

At this point all I can suggest is doing a fresh install of osmc:

Before restoring a backup or setting up a customization, check if you are able to connect to your wifi.

Regards Tom.

Is it 2.4 or 5 GHz? Which channels are configured?

it’s 2,4 GHz.
Channel 13 is configured.

Older versions of OSMC had issues with channel 13 due to CRDA issues. This has been solved in more recent versions.