Wifi issues - Fail to connect

My machine is Raspberry Pi 2b , install 3 days ago OSMC RC3, download windows installer, preconfigured the wifi , during the installation the wifi connect and download the updates. First run, the wifi connect an disconnect. Try to connect in menu MY OSMC and respond “Failed to connect”. Connect to ethernet, update the box, and try to connect other time, and other time “Failed to connect”.
Kodi log is:

19:51:39 T:2765169696 NOTICE: Attempting connection to /net/connman/service/wifi_6470022bc272_4f72616e67652d32454338_managed_psk
19:51:39 T:2765169696 NOTICE: DBusException Raised: net.connman.Error.NotRegistered: Not registered
19:51:39 T:2765169696 NOTICE: Connection to /net/connman/service/wifi_6470022bc272_4f72616e67652d32454338_managed_psk : False
19:52:53 T:2765169696 NOTICE: Starting Wireless Agent
19:52:53 T:2765169696 NOTICE: Setting password
19:52:53 T:2765169696 NOTICE: Attempting connection to /net/connman/service/wifi_6470022bc272_4f72616e67652d32454338_managed_psk
19:52:54 T:2765169696 NOTICE: Connection agent not started yet, waiting a second
19:53:08 T:2765169696 NOTICE: Previous line repeats 3 times.
19:53:08 T:2765169696 NOTICE: DBusException Raised: net.connman.Error.Failed: Input/output error
19:53:08 T:2765169696 NOTICE: Connection to /net/connman/service/wifi_6470022bc272_4f72616e67652d32454338_managed_psk : False
19:53:55 T:2765169696 NOTICE: Attempting connection to /net/connman/service/wifi_6470022bc272_4f72616e67652d32454338_managed_psk
19:54:08 T:2765169696 NOTICE: DBusException Raised: net.connman.Error.Failed: Input/output error
19:54:08 T:2765169696 NOTICE: Connection to /net/connman/service/wifi_6470022bc272_4f72616e67652d32454338_managed_psk : False
19:54:18 T:2765169696 NOTICE: Starting Wireless Agent
19:54:18 T:2765169696 NOTICE: Setting password
19:54:19 T:2765169696 NOTICE: Attempting connection to /net/connman/service/wifi_6470022bc272_4f72616e67652d32454338_managed_psk
19:54:31 T:2765169696 NOTICE: DBusException Raised: net.connman.Error.Failed: Input/output error
19:54:31 T:2765169696 NOTICE: Connection to /net/connman/service/wifi_6470022bc272_4f72616e67652d32454338_managed_psk : False

Any suggestion?.

Thanks in advance.

The installer does not connect to wifi - if you are referring to the triangular coloured OSMC install screen with a black progress bar it is simply installing onto the SD card from files the SD card. Wifi will not be active until the first normal boot.

Yes, please upload full logs with the log uploader - we can’t tell what’s going on from that small log snippet. Also describe your wifi configuration and model of wifi adaptor that you are using.

After installation my router registered a wifi connection from OSMC.
After the first start I got connected for a few seconds, the my adsl router´s log confirms this connect.

The usb adapter is:

TP-LINK TL-WN723N .

the complete log is in osmc log

thanks.

Your log shows multiple disconnects and re-connects. Please check that your power supply is adequate. This is triggering the device to be reinitialised (firmware download) repeatedly and explains why you have connection issues.

Sam

Hi,

It looks like you have a power issue - your wifi adaptor is dropping off the USB interface causing the driver to shut down, then the driver initialises again. This is happening over and over in your log.

Make sure you have a good 5v 2amp supply (try a different one if you have access to it) and make sure you enable max_usb_current=1 in your config.txt. (Can also be done in the Pi Config section of OSMC settings)

As a test if you have a powered USB hub you could also prove it by powering the wifi adaptor via the USB hub.

thanks. Change the power and i solve the problem.