Wifi issues since last update?

I have been having odd wifi issues since the last update. I am not sure if it is related to the update or not, but nothing else in my environment has changed.
I am running 2 RPi 3’s with built in wifi.I pretty much cannot even stream anything anymore on either one, youtube, shoutcast, and network shares. I have tried disconnecting and reconnecting the wifi on both and no changes.

Also, I have tried file copying and took over 10min for each one for a 133mb file.

Any suggestions of where to start? Is there a way to rollback updates without reinstalling?

Yes, logs as usual…

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Here you go: http://paste.osmc.io/uqahohajah
I started playing a movie from a network share and there was freezing. I can do more things if needed, such as copying files to/from smb shares, streaming from tvh server, etc…

Have you rebooted the router? If there was a widespread issue, there would be a lot more support requests over it.

Yeah, I have rebooted it a few times and no changes. My other G and N devices have no issues with speed.

I figures more would report it if it was an issue with a patch, but not sure where to go from here.
Should I try a apt-get update and upgrade as well as a rpi-update to see if it changes anything?

I am changing my wifi channel and extensions and seem to be getting better speeds. I’ll keep adjusting and see if I can get closer.

What is the max speed I could expect to see on a RPI 3 running wifi?

Never, ever run apt-get upgrade, or you’ll ruin your system.

It’s a 1x1 802.11n, so about 40Mbps is the best you’ll get in the real world.

Thanks, I thought there was one that I wasn’t supposed to run.

I changed some wifi settings in my ddwrt router and seems to have fixed the issue now. Not sure what was changed, but thanks for pointing me in the right direction.