WiFi login failed Atheros AR9271

Hey Guys,

As some add-ons on raspbmc were very corrupted and internet quite unstable, I bought another dongle (Atheros AR9271 chip) and decided to upgrade to OSMC RC3.

The adapter is recognised this time, however when entering the WiFi password the connection fails. I’ve tried multiple times and am quite confident most of my attempts were correct.

Any clues on how to solve this?



Have you tried running updates over Ethernet first, then connecting to Wifi ? Some wifi authentication bugs have been fixed since RC3.

Thanks. I have RC3 installed. Unfortunately I’m not able to connect via ethernet… If I was I wouldn’t be messing with WiFi :smiley:

You might be stuck then. The most recent updates may fix your connection problem but you would need to temporarily connect via Ethernet to install them. (Or try a different wifi adaptor or wireless network)

Solved indeed with the update. Enabled the ethernet adapter and scheduled the update time. Managed to plug it into a modem somewhere and hoped the update would be installed overnight, which it did.

Glad to hear it fixed the problem - there is an option to initiate an update immediately by the way - under manual controls - Scan for updates now.

Yes, but I did not have the option to connect both ethernet and a screen. Therefore I was unable to activate the update while having an internet connection!

You can initiate a full update via an SSH session by doing:

sudo apt-get update && sudo apt-get dist-upgrade

Followed by reboot when done. In fact I’m surprised that automatic update worked for you with no TV and no input device, because for most updates it will still prompt you for an exit or reboot before installing updates, so is not fully autonomous…

Have you tried running updates again since you connected to Wifi ?

Yes. Nothing happened. Must have gone right.