WiFi not working properly


I have a raspberry Pi3B with a 2.5A powersupply, brand new out of the box. Have installed OSMC to a 8GIG SD card and added the wireless network while installing via my laptop to the SD card. I only have WiFi so no other ways to connect to the raspberry Pi. The problem I am facing is the following. After doing all steps to install is says there is no network. Then I go to the OSMC settings to network. Now it finds 2 of the 10 WiFi signals that are available in my house. I connect to one and it does not connect. Then the SSID just dissapears from the wireless connection page. I can now never get it back. I tried versions 2018.03-2 2018.02-1 and 2018.01-1. Every time the same problem. Tried a different power adapter but that gives problems with the bolt in the right hand corner (its a 2A so thats logic). Cannot create log for there is no connection to make to the Pi. Is my Pi broken or can you advise on a way to go forward?

Thank you.

In cases where you have no network connection, you can write the log to the SD card either from the My OSMC Kodi interface or from the command line by running grab-logs -A -C

Then shutdown OSMC and transfer the card to your laptop. On the laptop copy and paste the file uploadlog.txt from the SD card’s first partition to https://paste.osmc.tv