Wifi problems Vero 4k

Dear all, hope someone can throw some light here. I just got a Vero 4k. It came with firmware from nov 2020. I connected it to my 5g Wifi without a problem. Updated to the latest firmware (dec 2021. Not without needing to hot fix updating problems too…) and after that it cannot see my wifi anymore. Tried with ethernet cable and searched for updates. It says there are no more updates available. It connects to my 2.4Gh wifi, but extremely weak and unstable, connection dropping all the time and really slow. Any ideas what to do in order to fix wifi again? Very frustrating, cause I can only use wifi here. All help appreciated, thanks!

We should be shipping much newer firmware than that. Do you have an order number at hand?


This is an original Vero 4k (not Vero 4k+) I got second hand in my area (Denmark). So nope, unfortunately not order number. I just need to have bluetooth for my Logitech harmony remote, wifi and HDR to SDR conversion working. Right now after a fresh start with the latest build (Isn’t that dec 21??) I got HDR to SDR but both bluetooth and wifi are not working

Posting some logs may give some clues.

This is what I did so far:
-I downgraded again to update nov 20: wifi and bluetooth works perfect again.
-I then upgraded via the in-built Upgrader to last available version (dec 21) Then wifi and bluetooth are broken. Thankfully it remembers my Harmony remote from pairing it while in the old version.
-It feels like after the update it cannot see my wifi extender Netgear EX8000 and therefore cannot connect to wifi.
What happens to wifi and bluetooth when updating?? Why can I connect to my 5g fast wifi with version nov 20 and not with the latest one? Do I need to choose between wifi and bluetooth or HDR to SDR conversion?
I will happily post those logs if I knew how?
Thanks for the help

I also connected wirelessly to my iPhone in order to download more possible updates…still cannot see or connect to my 5g wifi…

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Here you go:

https://paste.osmc.tv/ xemunulana

Sorry, try again:


You can try the staging repository or wait until tomorrow’s update.

Have you tried to determine what Band and channel your Vero is using I had a problem similar to this when our cable company sent out a new router … they locked the stupid thing to N band only and channel in auto mode. I had to hack it to make a change to the 5 g settings for B and G bands so my laptop would see it… It canceled out the 4 g so I couldn’t connect ether way.

Yeah, I suspect it might be something like that. But then why can Vero connect to the extender in OSMC version nov20 and not now with the latest? Has something changed in the wifi configuration considering Band and channel cause of the update? Could that happen? But I will definitely check in the extender settings, thanks!

I will update today, thanks!