Wifi stopped working


I recently bought Vero4k. I installed and configured all, and works great. Nice device!
I also installed raspotify (according this instructions: link)

Then I listened to music through that, stoped that, and let the device run. The next day the Wifi is not connected anymore. In the OSMC settings under network it does not show Wifi anymore. When I connect via cable and try things on the terminal I cannot find any reason for it.

dmes shows the following:

osmc@osmc:~$ dmesg | grep wifi
[ 0.253107] wifi: power_on_pin_OD = 0;
[ 0.253117] aml_wifi wifi.32: [wifi_dev_probe] no power_on_pin2
[ 0.253145] aml_wifi wifi.32: [pwm_double_channel_conf_dt] pwm phandle val=25;pwm-channel1=4;pwm-channel2=12
[ 0.253151] aml_wifi wifi.32: [pwm_double_channel_conf_dt] pwm_config1[0] = 30541
[ 0.253157] aml_wifi wifi.32: [pwm_double_channel_conf_dt] pwm_config2[0] = 30518
[ 0.253163] aml_wifi wifi.32: [pwm_double_channel_conf_dt] pwm_config1[1] = 15270
[ 0.253169] aml_wifi wifi.32: [pwm_double_channel_conf_dt] pwm_config2[1] = 15259
[ 0.253175] aml_wifi wifi.32: [pwm_double_channel_conf_dt] pwm_config1[2] = 6
[ 0.253180] aml_wifi wifi.32: [pwm_double_channel_conf_dt] pwm_config2[2] = 9
[ 0.253186] aml_wifi wifi.32: [pwm_double_channel_conf_dt] wifi pwm dt ok
[ 0.253205] aml_wifi wifi.32: [pwm_double_channel_conf] wifi pwm conf ok
[ 0.253245] aml_wifi wifi.32: [wifi_dev_probe] interrupt_pin=241
[ 0.253252] aml_wifi wifi.32: [wifi_dev_probe] irq_num=100, irq_trigger_type=1
[ 0.253258] aml_wifi wifi.32: [wifi_dev_probe] power_on_pin=240
[ 0.253263] aml_wifi wifi.32: [wifi_dev_probe] clock_32k_pin=0
[ 0.253381] aml_wifi wifi.32: [wifi_setup_dt] wifi_setup_dt
[ 0.253409] aml_wifi wifi.32: [wifi_setup_dt] interrupt_pin(241)
[ 0.253429] aml_wifi wifi.32: [wifi_setup_dt] power_on_pin(240)
[ 0.630189] efusekeyname: mac_wifi offset: 12 size: 6
[ 3.883042] aml_wifi wifi.32: [extern_wifi_set_enable] WIFI Disable! 240
[ 4.185830] aml_wifi wifi.32: [extern_wifi_set_enable] WIFI Enable! 240

connmanctl shows the following:

connmanctl> technologies
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False
Name = Bluetooth
Type = bluetooth
Powered = False
Connected = False
Tethering = False

So I really wonder what is wrong here.
Thanks for the support

Does a re-boot fix it? It did for me yesterday when that happened.

Paste a full log, not a snippet.


Hello, thanks for the reply.
Reboot I tried several times, nothing changed unfortunately.

What log? Whole DMESG output?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thanks for that!

here is the URL Logfiles

I would recommend reinstalling OSMC.

If you then have no joy contact support@osmc.tv for a replacement.

ok, you have a howto?

Yes. See Reinstalling OSMC - Vero 4K - OSMC

Thank you so much for the fast responses. Guess I have to send it back then, same result. No Wifi selectable.

I also am having this issue, the logs are a clean reinstall, and the problem still persists.

Can you try a full power cycle (leave the device off for one minute)?

Same error, No wireless connection.
New logs here:

Sorry to hear this. Please contact support@osmc.tv so we can look in to this further.