Wifi tethering not working on Pi 3

I have a Raspberry Pi 3 with the latest OSMC installed.

It’s connected to LAN using the ethernet port.

I tried to enable WIFI tethering from the ethernet to Hotspot,

But it gives me this error “Error enabling hotspot check logs”,

I don’t know how to check logs but I search about this issue in google.

I have found the command ‘connmanctl tether wifi on’ I did it on SSH and it says permission denied even with sudo.

I also re-flashed the image file of the OSMC, I got the same results.

What can I do?

Well first to check logs do sudo journalctl and that tethering is not working might be caused by the current Pi3 driver not supporting tethering

Here’s the log when trying to enable hotspot:


Help me figure it out :slight_smile: thanks.

I don’t think it is expected to work. BCM43xx does not implement nl80211 which is needed for tethering via connman

I used this tutorial https://frillip.com/using-your-raspberry-pi-3-as-a-wifi-access-point-with-hostapd/

Everything worked fine except upon boot the system tried to enable the interface wlan0 which is the wifi module but rfkill prevents it to enable because it keeps the wifi modue on soft block.so it leads to a failure.

If i do modinfo rfkill it says by default it disables all radio.

How can I prevent rfkill from soft blocking the wifi by default or execute ‘rfkill unblock all’ on boot to be able to enable wlan0?
It seens to have to do with osmc and power saving how can I disable that?

1 Like

rfkill is used to block WiFi / BT. It’s useful for power saving on laptops etc, but has nothing to do with internal power saving on the adapter which is disabled by default on the latest version of OSMC.

Don’t configure rfkill and you won’t need to do anything with it. To clarify: rfkill completely disables the radio (bluetooth, wifi etc), but BCM43xx has its own cfg80211 based power management in the driver. This is now disabled out of the box, so you are getting the best performance already.

Re. hostapd. hostapd will work as it does not explicitly need nl80211 but you will lose configuration from My OSMC -> Network


Thanks for explaining.
What do you mean by lose configuration?
And the hostapd seems to work the problem is with dnsmasq that needs wlan0 to run which os blocked by rfkill.

rfkill is not bundled on OSMC by default to my knowledge. Did you install this utility yourself? It’s not needed. You only want this utility for things like laptops where you are trying to save power.

dnsmasq is not used either on OSMC. OSMC has its own internal DNS proxy in ConnMan, but this is not used by default due to issues with large responses.

It’s hard to say what your issue is without a more detailed explanation as well as more background in to what you have actually changed.

By lose configuration, I mean that you will lose some of the flexibility of network configuration offered by our GUI.

Hey, first of all Im relatively new to Linux so dont expect me to understand everything.
What im trying to do is to create a hotspot frm Pi 3 wifi module with the internet from the ethernet port.

I have tried doing it using the GUI and then from connman and it didnt work.

Then I found that tutorial and followed it exactly.
hoatapd works and opens a hotspot but dnsmadq fails to start and using systemctl the problem seemed to be with the wlan0 interface.
So I did ifconfig and saw that it is not enabled so I did # ifconfig wlan0 up and it gave an error saying ‘SIOCSIFFLAGS: operation not possible due to rfkill’ at that point I might have installed rfkill and then executed # rfkill unblick all then the interface could be up again, but dnsmasq still failed with the same error probally because of some sub-service that needs to be restarted.

Anyway you said that I can use connmn instead of dnsmasq how can I do that with hostapd?


Ops! Wifi tethering is working on osmc by default! I just had to click enable wifi adapter in gui then enable tethering.
To osmc - great work! But if wifi adapter is disablef dont let th tethering option because it confuses.

Thank you Sam for trying to help sorry for ur time :slight_smile:

Oh and how can I keep the wifi adapter on permantly on every boot?

I just noticed this and thought I’d chuck in a wee comment…

I’ve got the hotspot on a Pi3, with SSID and password changed, running and surprisingly, the throughput is much greater than via my Draytek access point.

I thought at first I was imagining it but nope, hammered it in various ways and on it goes, even through Pi reboots.