WIFI through USB on RPi1 (A and B+)

Hello all :wink:

I would like to share an issue that seemed solved in the past.

When I plug my Wifi dongle, it seems recognized, but for obscur reasons is quickly disconnected (extract of dmesg as “proof”)
Extract from dmesg

What I’ve tried yet :

Any idea?

That usually means a PSU issue. Which PSU are you using?

2Amp PSU… and I am sure it can deliver at least 1.2 Amp

I will try with new cable (shorter cable) (I’ve seen the lightning bold)

Lightning bolt means that the device isn’t getting enough power.
A lot of power supplies don’t deliver anywhere near the current they promise to.

Fix that first, and the problem will likely go away.

Where I am confused is that :

  • this is a 2A PSU (commercial description)
  • I have a USB power-meter (displaying voltage and current), showing 5,03V; seems good
  • when connecting my smartphone, it deliver between 1,16 and 1,24A; the app “GSam Battery Monitor” tends to confirm that value above 1A
  • when connecting the RPi, it delivers at max 250mA - 300mA :astonished:

OK, this device is probably not the best but give a good idea

I will try with an other type of 2A PSU and a shorter usb cable

Cable can make a very big difference

I’ve already seen old cables taking up to 300-400mA (and of course I dumped them)

Some update

I’ve tried with new PSU, lightning bolt disappear but same problem.

so :
1st : the first PSU I used is not in cause
2nd : the long cable I used drains some power but not that much
3rd : I’ve tried with an other PSU : no more lightning bolt, but same problem with the WIFI key
4th : I’ve tried with an other WIFI stick (D-Link DWA-140 to be precise) : it works.

In my opinion : there is still some issue with that realtek chipset :
USB: 0BDA:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

That issue is not specific to osmc, but seems to realtek in linux…

I don’t have the resources (time) to help compiling the specific module for that wifi stick, but I can test and help if wanted