Wifi Troubles

D-Link DWA-171

Since the update to OSMC October 2015.10-1
(before the update dwa-171 did not detect)

I am able to enable the wireless adapter, connect to a wireless network briefly,only after a fresh boot.
Wireless connections do not hold for more than a very very short time. Able to push a little bit of data, but the connection drops and no SSID’s are listed when I check the wireless network.
Wifi scanning results are limited, if any listed at all, when I know that there are wifi AP’s in range.
Tried a few wifi routers and disabling security and same results as above.

Tried a higher amp power supply (2.5 amp).

lsusb -D /dev/bus/usb/001/008 -vvv | more


Product name: D-Link DWA-171
Device: ID 2001:3314 D-Link Corp.
Device Descriptor:
iLength 18
bDescriptorType 1
bcdUSB 2.10
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize 64
idVendor 0x2001 D-Link Corp.
idProduct 0x3314
cbdDevice 2.00

Chipset is not listed, but this I think it is RTL8821AU

lsusb -vvv -t


Which I think is the right driver.

I do not know if this is suppose to be a supported chip, posted this in the official Wifi support request page, but not sure where to go with this from here as no reply so far.

Let me know if any more info is needed. I could not figure out how to output the lsusb -vvv results to a file. So had to do it the old fashioned manual type out.
Please help me and my OSMC media center :smile:

is it A1 or B1 cause one use Realtek RTL8811AU the other MediaTek MT7610U on another note if you want to be free of the hassle of dongles check the thread below :smile:

it is an A1
I know a cable connection would be the idea, but my house is not from an ideal world for running ethernet unfortunately.

cable connection to a wifi brigde cable doesnt have to be more then 0.1m

Your dongle is already supported. If it wasn’t, the system would simply appear as if the dongle were never connected. The issue is simply that the current driver for it is either very flaky, to which @sam_nazarko has said several times lately that overhaul of wireless driver packages is receiving a revamp soon, or the issue is simply a problem of range/interference/incompatibility/misconfiguration among your current networking hardware. Have you tried changing wireless channels in your router?

hey Toast, yeah i didnt get the wifi bridge on my initial skim read. WDS takes a fair hit on through put, but yes it is a solution that I’ll admit i did not think of.

ActionA, tried different channels on 2Ghz and 5Ghz, no encryption and encryption. Blazing signal strength at at 2 meter range (while i do the setup in a different room). I have looked at the interference or SNR levels. Tried a different Router AP. Would like to avoid buying another wifi adapter just for driver support as this is a dual band adapter and perfectly fit for purpose.

My thoughts are that the driver or config is flaky. And I would like to be able to provide help with adding my wifi woes for future hardware support.

Wifi adapter works fine on other devices and Wifi works fine with other devices, have tried fresh installs of OSMC with updates via ethernet.