Win32 Disk Imager alternative

Hi,

Do you know of an alternative to Win32 Disk Imager for backing up my SD card ?

I have the impression that it no longer makes a clean backup, when I try to open my backup it tells me error

What error do you get?

when I try to open it with 7zip for example, “disk image file is damaged”

It doesn’t do it for me on previous saves, I can view folders containing

Hopefully Sam can help you sort out the issue, but if it persists there’s always Balena Etcher

Two things that may help as well, sometimes in Win32 Disk Imager I forget to add the .img extension when creating a new image. Although I don’t think that’s likely to be your problem here I thought I’d mention it just in case.

Try using for example “Win32 Disk Imager VS” in a search engine. I learnt this long ago when looking for pieces of software that do similar things.

Well, from the logic there could be also a problem with your SD card?
Do you have another free SD card you can format, put some files on it and use the Win32 Disk Imager to create an image from?

I didn’t think Etcher made backups, but I’ll give it a try and see.

EDIT: it does not allow backup, only cloning

So I tried to put the bakcup made with Win32 Disk on another SD to see if it was a problem… I found out that it wasn’t. I was able to boot on osmc.

I installed the 1.0 version on Windows 11, put some files on a 2 GB sd card (FAT32) and created an image file with it. 7zip could open the image file without any issue and show the content.
The only trick was to stop the google drive app otherwise you cannot start the Win32 Disk Imager.

Will retry now with a 32GB sd card from an OSMC Pi4 but that could take some while.

That does not mean the sd card is fine and/or the OSMC file systems are completely intact.
What about formatting a free sd card and copy some files to it? So, the idea is to not use the possibly corrupt OSMC image.

I don’t know, I think it’s not how to check the completeness of my system. is there a command for that ?

So, as assumed there is no general problem using Win32 Disk Imager even on Windows 11: The OSMC RPi4 SD card’s image by Win32 Disk Imager could be opened by 7zip without any issue.

So, what can you do?

  • There is no tool to check the completeness and correctness of OSMC files afaIk.

  • The RPi sd card contains an MBR partition table (which I think is the problem) with two partitions: A small FAT32 partiton and an Linux partition with the ext4 file system.

  • Windows can only see the first FAT32 partition but it’s worth a try using ‘chkdsk /f’ in an administrative cmd input window to check the first partition using its drive letter. If you’re lucky, that’s it and 7zip can open a new created image file without an error.

  • if not … you have to be sure the sd card is physical intact:

    a) First make another image backup.

    b) put the sd card in your Pi and make an OSMC backup under Settings → My OSMC → Updates → Backups, a large USB stick with an exFAT file system could be helpful. This only creates a backup about the mediacenter settings.

    c) format the sd card using the formatter suggested by the SD Association: SD Memory Card Formatter for Windows/Mac | SD Association

    d) Test the SD card: I suggest to use h2testw, use the translation function of your browser to understand this German website: H2testw - Gratis-Download von heise.de

  • if the card is not intact, you know the root cause otherwise you only know the card content is corrupt anyhow → time to re-install OSMC and try to restore at least the OSMC settings from the backup made in step b)

Let us know how this ends.

1 Like

Thank you for this long explanation :slight_smile:

this is the first time I’ve had this problem, I make regular backups, my other backups I could open with 7zip.

as i said, i installed this backup on another SD card and my rpi started up fine. so i think the backup is correct?!

I also tried the other SD and made a backup even though I can’t open it, I don’t think the 2 SDs are invalid.

i don’t see any other reason

Tbh, I can’t follow your logic. Try HDD Raw Copy Tool by hddguru.com to make an (uncompressed!) image backup to a file.

If 7zip still has problems opening this image, you have proof that something is wrong with your backup and sd card content and Win32 Disk Imager is not to blame.

How to further troubleshoot the issue, see above. Let us know what you found.

I just want to test with another app to see if I can use the backup file.

with HDD Raw it seems to work

Sorry – this is somewhat confusing.

I think you have a defective SD card causing corruption.

normally no, I’ve done the same with another SD and it’s the same result

I checked for an alternative too and here they are:
Rufus
ImageUSB (from PassMark)

And even if they work I’m stil usiing Win32 disk imager for SD and USB disk image creation (restore/duplicate done many time).
Even Img file of 256GB USB SSD open in 7zip (x64 23.01) with no issue at all.