Windows 10 Fall creators SMBv1 fix

From time to time i use my good old friend as a network mediaplayer. I use my Raspberry Pi3 mainly for streaming from my mobile phone, but i also like to watch movies from time to time. Unfortunately microsoft is a pain in the ass nowadays, and with support for windows 7 till 2020 many users are forced to use windows 10 instead.

On my windows 7 professional license everything worked like a charm, but with the latest updates microsoft shut down the SMBv1 support on windows 10. I’ve read serveral topics to solve to problem i had, but no succes. Since i and many with me don’t run linux some options like fstab become unavailable, atleast for me cause i simply dont have much knowledge about linux and their commandlines.

Allright done with the talk, lets get to bussines.

Step 1: Get the latest version of OSMC (Augustus 2018 build)
Step 2: After installation go to ‘MY OSMC’ click on ‘Store’ and download and install the SMB Client.
Step 3: shutdown Raspberry Pi3
Step 4: Go to windows and do a CTRL+S, when the search menu pops up type in: ‘Windows features’.
Step 5: Go install ‘Media Features’ and ‘SMB 1.0/CIFS File Sharing Support’
Step 6: Reboot your system
Step 7: Type CTRL+S again and type in: ‘Network status’ now click on ‘View network status and tasks’
Step 8: Click ‘change advanced sharing settings’
Step 9: On the private profile turn on ‘Network discovery’ and the checkmark automatic setup.
Step 10: Click on ‘All networks’ and turn off password protected sharing
Step 11: Boot up your raspberry pi3
Step 12: Go to ‘choose media streaming options’ and turn on media streaming. If it’s correct you should see your mediaplayer (OSMC device).

Step 13: Go make a shared folder on your windows machine, after that get into OSMC.
Step 14: Add a new network location and type in: smb://PCNAME/location and you should be done. Replace PC NAME with your own, and location would be the folder you’ve shared offcourse.

Make sure to set a password to your windows account, as this makes it easier to connect. When you find it annoying to type in your password everytime your PC starts you can type CTRL+R and type in Netplwiz and uncheck 'users must enter a username and password to use this computer.

If above steps don’t work shut down your PC and your raspberry, first turn on the raspberry and let it boot. After it’s registered on the network start your PC and try again. Also make sure the raspberry and your PC are in the same WORKGROUP.

It should work 100% atleast it did the trick for me. Hope this helps everyone to solve this problem once and for all and enjoy your osmc like the days you were on Windows 7.

Greetz and take care,


Good advice, thanks. So is there anything in Fall Creators that’s changed? That’s pretty much how we had to do it before.

Since microsoft decided to stop the SMBv1 support many people had problems connecting their osmc to PC, just to share folders to play movies and music. This simple fix reinstalls SMB 1.0 and let you enjoy the oldschool functionality how it worked on windows 7.

I know, but that happened a long time ago, and we covered it here.

Just wondering what’s new now. Can you suggest any tweaks to that post?