Windows 10 shares smb or fstab

I’ve had a 4K for a while with w10 pc smb shares connected and working. I have a newer w10 pc and I want to share from that instead so I can turf the old one. I’m having trouble sharing to the 4K

I’ve read a few threads and I’m sure I’ve covered the obvious traps.
-Network “advanced sharing” settings are all good to go.
-The pc has a local account. Password protected sharing is turned on.
-The folder is shared on the network with password protected sharing
-smb1 is ticked in programs and features.
-On the 4k I have smb minimum - none, smb maximum smb 3.
-I can add the network location to the list in the 4K and when I click on that it shows the folders inside it
When I try to add it as a source including my windows username and password I get “operation not permitted” - ok - then

couldn’t retrieve directory information. this could be due to the network not being connected. Do you want to add it anyway?

yes does not result in success.


I looked at the guide for fstab mount but I can’t code. I can ssh in by putty but after that all I can do is paste in instructions without understanding

I tried to follow the guide on the wiki Configuring fstab based Samba share mounts

ssh in, good

  • enter $ sudo nano ~/.credentials
    -command not found

Anyone patient enough to help?

We can go through this. If you are willing to move to Kernel Based mounts (instead of Kodi direct) I would recommend that you go using autofs.

But let’s start with the first step.


Based on the above picture sudo nano ~/.credentials should work.
What does which sudo gives you?

Am I supposed to paste it as “$ sudo nano ~/.credentials” or without the $



1 Like

I tried it with out the $ and it opened a thing

Thanks I’ll work on that for now

Yeah that would be the editor where you can write in the credentials and close/save with ctrl-x

1 Like


after the mount didn’t work I changed the Server_Movies to Movies7 and I checked and fixed the ip address

any hints?


What’s the out put of mount /mnt/Movies7?

Also suggest to check the samba share

sudo apt-get install smbclient
smbclient -L -U my_username

Also share the fstab with paste-log /etc/fstab and write the URL



That seems not vaild, can you check for typo.

BTW you don’t need to post screenshots. You just can mark/copy/psate the text from Putty here just use </> button above on the text afterwards.

Can you try mkdir /mnt/Movies7 and then mount /mnt/Movies7

1 Like

osmc@osmc4K:~$ mkdir /mnt/Movies7
mkdir: cannot create directory ‘/mnt/Movies7’: Permission denied
osmc@osmc4K:~$ mount /mnt/Movies7
mount: /mnt/Movies7: No such file or directory
osmc@osmc4K:~$ osmc@osmc4K:~$ mkdir /mnt/Movies7
-bash: osmc@osmc4K:~$: command not found

Try sudo mkdir /mnt/Movies7 and then sudo mount /mnt/Movies7