Windows 10 smb share on new vero 4K

I have a pi that has osmc and just got the new vero 4k.

I can’t add a source via videos/files/add videos/browse. …Nothing comes up.

I tried typing in the share location smb://DESKTOP/TV Shows …I get operation not permitted

Then I got - Couldnt retrieve directory info due to network not connected, add anyway?

I tried smb:// Shows I get operation not permitted.

I have the folder shared to everyone and the W10 machine has a username and password.

I read sevearal threads here and i can’t find the answer

The vero is connected on to the intrenet and shows up as a device on my router.

The other thread said that smb shares no longer work due to wanna cry is this true? is there a way past this? … if that helps

Well that is not correct in that way. SMB Browsing (a feature of SMB1) is not available anymore since a Wannacry security update.
But adding the sources manually should still work. I think the easiest for you would be either of these to steps:

  1. Copy the sources.xml and passwords.xml files from your pi (folder .kodi/userdata) to the vero4k
  2. As an alternative use fstab based samba mounts they are also more performant Configuring fstab based Samba share mounts

The logs seems empty

Still it is empty. Anyhow do one of my suggestions.
And also remember this

I tried the fstab instructions which resulted in no added sources. perhaps there is some detail I got wrong.

Can you tell me how to move the files?

Well after mounting the shares via fstab you then need to add them as sources via Rootfolder -> mnt -> your share

Well either you copy them via your PC (e.g. winscp) or the easiest directly from your pi to the vero. On the pi:
scp .kodi/userdata/sources.xml <IP-of-your-vero>:/home/osmc/.kodi/userdata/
scp .kodi/userdata/passwords.xml <IP-of-your-vero>:/home/osmc/.kodi/userdata/

so I just enter those commands into putty while connected to the pi?

Yes, while I still would suggest to use the fstab method especially if you already done the mounting part

I tried transferring the files via putty but that didnt add access. The pi that has access to the folders does not come up with browse options when you try to add a source either.

I followed the fstab instructions up to:

At this point, your shares should just work. To test, simply try to go to the share:

$ cd /mnt/Server_Movies
$ ls

and it comes upfstab fail

Did you restart Kodi?

Post cat /etc/fstab | paste-log and dmesg | paste-log

Thanks fzinken.

I’m sure the file transfer method is what worked. I understand that it may not be the most ideal.

heres the outcome of fstab method in putty.fstab ls

I don’t think it worked. I’ll stick with the current setup

That’s OK, just your last message was it didn’t work.