Windows 10 Update 1803 - SMB Issues - IPv6 (Fixed?)

Not sure if this will be helpful, or if I committed a grave sin, but I did it anyway. After updating to W10 1803 on my backend, my SMB completely died. All I would get on OSMC was “connection timed out”. I tried just about everything to fix it multiple times since April. The only previously successful solution was rolling back Update 1803 on the PC.

Yesterday, I was able to resolve the issue by going to the Network and Sharing Center and unchecking the box for IPv6, and everything instantly worked. I do not understand what exactly this did, and what the ultimate pros and cons are of this solution.

Anyway, everything is running perfectly - I would like to better understand why this random hunch worked… (or at the very least to help someone else with the same problem).

OSMC - RPi3(s) with current stable release on Ethernet
PC - Windows 10 Pro Creators 1803 Update on Ethernet
SMB - Set to highest with Username/Password


From some googling this seems to be a common solution for this problem. I can’t see this being an issue, unless your isp changes to full ipv6. I can’t see this being a problem for a while yet and hopefully by then microsoft will have fixed its issues with ipv6.

Thanks Tom.

Hello Tom,

Thank you for the reply! Of course more fun happened when I got home from work yesterday afternoon - SMB was not working again. Windows 10 completed additional updates, and this time I had to RE-ENABLE IPv6 and it instantly started working again.

All I can do is hope to learn something and help some other folks.


enable or disable?

Sorry for the long delay in responding to you!

At first I needed to DISable IPv6 to get it to work with the installation of W10 Update 1803. The next day it stopped working again, and I ENabled it again and it started to work. No issues since I did this almost a month ago.

I did have an issue where Windows 10 decided my network was public and stopped sharing (after a router firmware update). That was a frustrating five minutes, but noone was injured.