Windows 7 shared folder not reachable with pi

Hello everybody,

i have an issue with my RPi to connect to a shared folder by windows. Before i installed OSMC i had raspbmc and there it worked very well!

I selected “search videos” and there i selected Windows network (SMB). But when i enter that there comes nothing.
I also tested it the manually way.
With IP adress
Folder name

Then i get a Error message: Connection timed out.

I am not very good at reading codes of the rasp but i hope you guys would be so kind to teach me that what i need!
I would be very happy when you can help me! :smile:
Thank you!


Have you used the forum search to see similar issues?

Can you upload the Kodi.log so we can see the issue with connecting? It is very likely a permissions related issue.

yeah i searched a lot and i tried a lot of it but nothing helps.
Maybe i am too stupid to find the solution.
I also installed the samba app but nothing works. :frowning:

i will upload the kodi.log in a few minutes, because i reinstalled it and now i have to wait for the final installation.

There is the kodi.log code:

Does the PC the pi is trying to connect has local ip for sure ?

Yes, for sure! Is the path I made true? I mean the positions of the ip and names of the folder.
It’s difficult because I connected with the old raspbmc to my server before and everything was good!

Is at osmc anything different to the raspbmc?

I am a little bit frustrated about that. :frowning:

i will reinstall the old good raspbmc. :frowning:
… for now

or does anybody have any idea why my smb is not working?

I found the failure by myself!! :smile:
Look here for every who have the same issue:
From the kb, edit the following entry:
Your choices for this registry key are 1,2 and 3.
1 = Minimize Memory Used
2 = Balance
3 = Maximize Throughput for File Sharing and Maximize Throughput for Network Applications

At my server there was it set to 1. I set it to 2 and it worked!

Thank you anyway for help! :smile:

Many thanks, that worked for me. No idea how the setting got changed; havent used the PI for a while and it had stopped working, till I set it to 2. Weird