Windows Installer Error

Windows 7 and OSMC Installer downloaded today.
I get an error attempting to run the installer app “the application has failed to start because its side-by-side configuration is incorrect”
Any Ideas? Thanks

Edit: An OSMC Installer downloaded in February does run on the same PC.

Apparently this can be because of a faulty C++ redistribution package on your system.
Our installer is statically compiled however…

Try extracting the EXE using a program like WinRAR and see if you can then run the program

Hi Sam,
I extracted qt_host_installer.exe with WinRAR and I still get the same error attempting to run the app.
I also checked for Registry issues but none were found.
I also installed Visual C++ Redistributable Runtimes and this also did not fix the error.

I’ve just tested this on a fresh installation of Windows 7 SP1 and all updates and it’s working.

Maybe Event Viewer has some clues

Make sure you are running the application as Administrator.

Thanks Sam,
I did run as administrator without luck.
Using the OSMC Installer that I downloaded back in February I had no problems installing and the system is now running the current version of OSMC.
That doesn’t solve this problem of course but it achieved the desired result.
I’m still unsure what the problem actually is.

We made some changes around that time to the application manifest to better support HiDPI modes. I’ll check it again shortly.

Thanks for confirming an older version works better. This is useful to know.

Can you just confirm that your W7 system is completely up to date?


Hi Sam,
there were only a handful of optional updates that I have now installed. Unfortunately the issue persists.

Can you post a screenshot of winver?

I had the same error, event viewer log:

Fehler beim Generieren des Aktivierungskontextes für “C:\Users\mlans\AppData\Local\Temp\RarSFX0\qt_host_installer.exe”. Die abhängige Assemblierung "Microsoft.VC90.CRT,processorArchitecture=“amd64”,publicKeyToken=“1fc8b3b9a1e18e3b”,type=“win32”,version=“9.0.21022.8"” konnte nicht gefunden werden. Verwenden Sie für eine detaillierte Diagnose das Programm “sxstrace.exe”.

i have lots of MS Visual C++ Redistributables installed (2005, 2008, 2010, 2012, 2013, 2017) but obviously not the right one. Probably because it is searching an “AMD64” platform which is not available on my 32-Bit Windows system.

Is there also an Installer available for 32-bit ?
Would be good to have in the program description mentioned that it is only 64-bit (even though it says Win XP +).

I have made the image then on my other PC with 64bit Windows.