Windows SMB share issues... again

Morning all,

I’m having a rather strange issue on my current setup.
I’ve got to Vero 4K+s and one older Vero K all connected to a Windows 10 “server” running a MySQL database using MySQL Community v5.6.51.0.

The following xml files are the same on all three boxes: advancedsettings.xml, mediasources.xml, passwords.xml, and sources.xml.
What is happening is that randomly Kodi (on any one of the three boxes) is unable to connect to one or more of the sources with an error popping up - “Operation not permitted” followed by “Couldn’t connect to network server” when browsing Settings->Media->Library->Videos.
The specific source changes randomly, and can appear and disappear randomly. Obviously this causes issues with updating/cleaning the library after adding/changing files, and watching local content from the server.

What I’ve tried so far:

  1. Replacing my router with a different one from another manufacture.
  2. Wiping one of the Veros and staring from a fresh install using versions 2022.09-1, 2022.10-1, and 2023.01-1. All sources were added again from scratch on each version fresh install.
  3. Wiping the server and reinstalling Windows 10, then setting up each of the SMB shares again following this forum step-by-step guide.

None of these actions have cured the fault, so I’ve run out of ideas. This issue has appeared relatively recently (no exact time scale or Kodi version I’m afraid) and I’ve never had any problems with my setup prior to this happening. I am able to browse all SMB shares from another Windows 11 PC (LAN) and Windows 10 laptop (Wi-Fi) connected to my network without issue and none of the shared folders disappear.

One thing I noticed on this Wiki article is that with the WS-Discovery protocol implemented since v19.1 I (think I) should be able to select Windows network (SMB) from the Browse for new shares list, and see the shared folders on the server, however when I do that all that comes up is “Error2: share not available”.

Apart from the OSMC remote, LAN (or Wi-Fi) connection, and HDMI lead, nothing else is attached to any of the Veros. All are running 2023.01-1 at the moment with minor addons to get full functionality. The issue appears whether running the default OSMC skin or Estuary. For simplicity, testing was done on a Vero 4K+ that is connected via LAN.

Debug logging was enabled and the Vero rebooted, I then navigated to Settings->Media->Library->Videos and tried to browse all my sources. When the error appeared, I collected and uploaded the logs here.
Around line 21850 you can see the source “War Movies” is unavailable, but while I’ve been typing this post, I had another try and it is now available, but “More Kids Movies” is now unavailable.

Any help would be appreciated, thanks.

Briefly, I would suggest and recommend that you mount your SMB shares with the more reliable autofs as described here - Mounting network shares with autofs (alternative to fstab)

Have you tried setting settings>system>power saving>max wait time for network>?
Is perhaps your hard drives going to sleep and Kodi is timing out before they come back up? Once you try to play something and Kodi gets a failed response, I don’t think it actually tries again on subsequent attempts. Telling Kodi to exit to restart it normally would bring it back to actually trying again.

Thanks for the suggestions guys. Changing the network wait time had no effect so I decided to try the AutoFS route.
I Backed up my watched statuses with the Texture Cache Maintenance Utility then wiped my MySQL database. I upgraded MySQL to v5.7.40, wiped one Vero, then recreated my folder structure using autofs. After finding the new mounts in the mnt folder I rescanned and recreated the entire library. Everything worked flawlessly and I’ve had no browsing problems since. I also wiped my other two Veros and set them up the same.

1 Like

Excellent, glad to hear it.


Cheers Chris.
One thing I did notice during “cloning” Veros:
I used OSMC’ backup wizard and when selecting Autofs in the list of bits to backup my .smbcredentials file wasn’t backed up.
I recreated it after restoring the “clone” and everything was fine after installing AutoFS again.
Maybe something to look into…

1 Like