WinSCP and permissionproblems

i’m installing a few things to my pi and i always have to copy files to some folders.
Very often, it says Permission denied (3) and i’m not able to copy/change something…
The only solution if is to set chmod 777 but this can’t be a good solution!
What can i do?
For example, i want to add systemd.show_status=0 to my /boot/cmdline.txt but winscp says permission denied.

i already tried shell = sudo -s but it nothing happened.

What I recommend you do is you donwload putty and then in putty you connect to osmc@ipofyourosmcbox and then edit the file on the command line.

cd /boot/
sudo nano /boot/cmdline.txt
edit the file and then save and reboot.

Let me know if this helps! And ow yeah make a backup of the file!

It worked via Putty, but i can still see boot messages during the boot splash…

another trick for copying files to an osmc-box is to first copy them to the home directory of osmc
and then use putty to login in on the commandline. once logged in you can use the sudo command and do:

sudo cp /home/osmc/whateverfile /where/ever/you/want/ . <—mind the dot it is necessary, unless you want to overwrite! then it:

sudo cp /home/osmc/whateverfile /where/ever/you/want/whateverfile

Alsways make backups!! and think before hitting enter…

I do not know about that boot messages thing but I’l look into it (got it myself too)


What messages ?

Messages are only printed during boot if services are failing to start or taking too long to start. A picture of the errors would be helpful.

Since im using my spotify.service it does appear…
where can i see in putty these messages?


sudo systemctl status -l spotify.service

no problems.
service is running, there are no errors oder problems.
i think i see the boot messages since i enabled via systemctl

and systemctl also shows no problems or errors

If you enable “wait for network” you may see messages appear during boot. (One reason it is off by default)

This is because the wait-for-network.service introduces a deliberate startup delay (that delays specific other services) until the network is found to be up. Systemd interprets this as a service that is taking a long time to start, and because other services are waiting for this service to finish starting (including Kodi) after a while it notifies you that this service is still starting up.

There’s no easy way to disable this message but it is completely harmless.

What about my permission problem? :smiley:

EDIT: i can see that the bootscreens says something about "dependency failed " and something with network…
where can i see the boot log?

here are some “screenshots”
i just took some photos during the boot process