Wired Network not working and Blueray Disks not playing

Hi all,

I recently received my new Vero 4K, which I bought to replace a Zotac ZBOX AD02 running an older version of Kodi. I mainly used it to play music and movies which worked fine all the time. One thing was missing: Playback of Blueray disc ISO files. As I had read on a German forum, that Vero 4K is capable of playing BD ISOs I decided to order one. Unfortunately it doesn’t play BD ISOs at all. I tried different ones but the Vero 4K refuses to start playing them.
What can I do make BD discs play?

Another problem is that Vero 4K doesn’t establish a wired network connection. On first startup of the device it showed under wired network setting “Status: no wired connection” I’ve been using the same network cable and the same slot on the very same router as the Zotac box.
At that time wireless network was disabled.
Wireless network instead works fine but playing DVD ISOs from a Samba share is all but smooth and fluent. The same DVD ISO on the zotac box plays just fine. So I hope that this is just due to the slower wireless connection.
I also tried to setup the connection manually using the command line. But as there is no file “etc/network/interfaces” I stopped the attempt.

I hope anyone can help me on this issue. Thanks in advance


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

The first thing that should be worked on is Ethernet.
If you’re familiar with SSH (seems like you are), then the output of:

connmanctl technologies would be interesting. For Ethernet, I get:

Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False

Vero 4K does not yet support BD menus. So you need to select the main title, i.e. the M2TS file that corresponds to the feature.

Is this an OSMC thing, or a Kodi thing? Kodi 17 on a PC plays back some BluRays using the menu, but only for simple menus.

Kodi thing. You need proper BD-J support, which I believe is coming.

To add to the issue, if you don’t rip the disc yourself, you still may not be able to play back using menus. This is because some of the copy-protection breakers muck about with the Java, and often the rips you see available for download are done in such a way that it completely breaks.

My Netgear NeoTV 550 has full, licensed support for BD-Java, but no AACS (how they managed to get that past the BluRay licensing is still unknown), so it plays back proper decrypted ISOs (and even physical discs, using a USB BluRay drive) with full menu support, but if Java got broken by the rip process, then it’s even worse than Kodi, since it starts the menu and fails, and doesn’t fall back to playlists.

I have no idea how Kodi will manage to support this feature, since there is no step-by-step copy method to follow that works for every disc.

IIRC, Kodi will support building with libaacs. What we’ll get – I’m not quite sure yet.


Just saw you mention BD-J support and menu playback… I think over at Kodi they got the menus basically working for Blu-ray und UHD discs: BD and UHD BD Menu support

They’re talking about a late nightly of v18. Would this also work in the OSMC Leia test builds or could the support (which is mostly a newer libbluray and JVM present, I think?) be back ported to Krypton?

No — it can’t be backported to Krypton

The output of
connmanctl technologies
for Ethernet is:

Name = Wired
Type = ethernet
Powered = True
Connected = False
Tethering = False

Here are the logs:

When I select a BD ISO in OSMC a windows is shown that gives the choices:

  • Play main movie
  • Choose from all titles
  • Show Bluray Menu

If I select main movie, it will jump back to the main screen.

Please can you produce a debug log of this?

Today, when I tried to replicate the issue to produce a debug log, it always ended in the system crashing. So I never even reached the screen where I could select the main movie. DVDs played without problems.
You will find the debug log here:

Btw: Could you make anything out of the logs provided regarding the networking issue?

Your log doesn’t seem to show Ethernet as enabled.

connmanctl enable ethernet might help
connmanctl services would also be interesting to see.

Hi Sam,

when I produced the log file provided in my post 7 days ago, I first switched debug logging on, having ethernet enabled. Afterwards I deactivated ethernet and enabled wifi connection, so that I could transmit the log file.

Today I created a new log file, following the steps below:

  1. Disabling Wifi and enabling ethernet
  2. Activating debug logging
  3. Leaving osmc
  4. Typing “connmanctl enable ethernet” → output: “ethernet already enabled”
  5. Typing “connmanctl services” → no output at all, not even an error message
  6. Creating a copy of ~/osmc/.kodi/temp/kodi.log
  7. Rebooting system
  8. Disabling ethernet and enabling wifi to retrieve the log file copy from the vero 4k, using a ssh connection
  9. Uploading the log to https://paste.osmc.tv/oveloviwov.vhdl

Hope this helps to further investigate.

I really appreciate your efforts very much but I remember very well how much time I spent on setting up my old zotac box a couple of years ago, and this time I wanted the hassle free solution. And now I’m already stuck for more than a week with getting ethernet to work.

Something’s not right here and I’d like to get this resolved promptly. I understand your frustration with having to mess with something so trivial.

Can you try another Ethernet cable on a different port on the router, even for temporary testing?

Ethernet is used as part of the imaging and activation process before it leaves our facility; so it’s unlikely to be a hardware issue.

I’d recommend reinstalling OSMC if you can and if that persists, contact support@osmc.tv and we’ll swap the unit over for you.



Hi Sam,

today I tried two more ethernet cables on two different ports of a totally different switch - all of which are working without any issues with other devices. So I’m pretty sure that the problem is related to the vero 4K. As there is also the issue with not playing back bluray discs I would reinstall OSMC following the instructions given under Reinstalling OSMC - Vero 4K - OSMC .
Let’s see what happens.

Best regards


After reinstallation the device still shows the same behaviour. I will send a claim for replacement to the customer service.

Do we have a log of you attempting to play back a BD disc?

Only unencrypted discs will play; and there is no menu support at this time. You need to select the M2TS manually.

I posted the link to the log earlier in this thread. Here it is again.


Thanks for this and sorry for the delay in reply. I’ll see what can be done here.

Is this an MPEG2 BD-DVD?