Wired playback worse than wireless playback

Hi guys,

Normally you hear people complaining that their wireless speed is bad.
Well for me it’s the opposite: I’m running OSMC on a Raspberry Pi3 and the wired network playback is horrible vs wireless playback,
I’m playing the media from a NAS. From other places I can play media from the NAS just fine. On OSMC on wired connection I get about 0,4 frames per second and extreme lagging. So I can say nothing can be played, regardless of media.
If I play from USB or wireless everything is fine!

What did I try:

  • Change the shares on the network from Samba to NFS; → no result
  • Mounted manually the shares on /etc/fstab; → no result
  • Changed the RJ45 port from the router; → no result
  • Changed IP; → no result
  • Tried using older OSMC release; → no result
  • Try OpenELEC; → no result

Looked on the console, the network speed was negotiated fine. I ran an iperf test between the NAS and OSMC, got around 90 Mbps for both TCP and UDP.

What else should I try? Any ideas? :slight_smile: I’d really like to stick to a wired connection if possible.


Wired is definitely to be preferred.

This suggests that it’s not an OSMC issue.

Does ethtool show that the connection is full duplex?

If iperf looks good then it doesn’t look like hardware. You can still see what’s happening on the network using iftop and nethogs. Maybe they’ll show something or provide a few pointers.

Try a different cable as well…

Are you using static or dhcp for IP addresses?
Are you sure there isn’t a conflict?

(Try pinging Pi’s IP address and check it no longer responds when Pi is unplugged).

Why you think it might be an IP address conflict if iperf seemed to work just fine? (Not saying it isn’t but what’s your line of reasoning?)

I’ve experienced really poor nfs speeds on a network with conflicting IP addresses.

It is just a guess. There are many possibilities and this is one error it is worth ruling out.

Ok, thanks. “Bitter experience” can be very helpful later on - though it doesn’t usually feel so at the time.

Hi and thanks!

I tried both DHCP and static addresses and different ones. Now I am on static as I like to have static addresses in the house. ehtool shows full duplex. The same cable was used with a commercial player and it worked ok, for even 1080i.
I will have to try some NFS tuning. Actually initially I had problems with Samba and that’s why I moved to NFS. After mounting with Samba it kept asking for details over and over and not saving the connection. I read it was something to do with latest Kodi or something. I will try to mount in fstab with Samba and see if it goes. Who knows, this one I haven’t tried :smile:


Have you tried to play the respective file locally instead of samba/nfs to first determine the issue is network related

Did you also tried “reverse”? Because by default iperf send from client to server

Could you show us the /etc/fstab lines you used on OSMC to access the NFS share?
And run cat /proc/mounts on the client (OSMC).
And I guess NAS /etc/exports to complete the picture.

Also, what’s the NAS?

Edit: clarified what I really meant to say. :wink: Hat tip to fzinken.

I will repeat the tests in the weekend. I think I tried bi-directional iperf but not sure, i will repeat. Yep, I played that file locally, not an issue. Also I’ve played the files on a commercial older player via Samba and they worked.

The NAS is a FreeNAS 9.1 with latest updates. I will let you know, definitely want to solve this and to let others know what would be a troubleshooting workflow and solution.

Thanks, cheers!