Wireless network option is missing

I am facing a very strange issue :
Today, I tried to turn on bluetooth on my pi3 i order to connect a bluetooth speeaker.
I couldn’t find my speaker with the pi, so i tried to reboot it, just in case.
After the reboot I couldn’t find anymore the bluetooth option in the My OSMC>Network menu. Actually now i can only see to options : Wired and Mysql. No more bluetooth, wireless, and the other.

Well, i could not figure it out, so i decide to install a new osmc from scratch. formatted my SD as usual, downloaded latest release from last june, etc.
But after language setup, bluetooth and wifi options were still missing …
I decide to install an older version of osmc (the one that was on my pi before all this) from january 2020 : same result…

If anyone can help, you’ll be most welcome.
Here is the log file I could get from the january version. : uploadlog.txt - Pastebin.com

It’s a bit strange but might, unfortunately, be a hardware problem. We’ve seen such failures from time to time on this forum.

To get a better idea, please run the following commands:

sudo apt-get update
sudo apt-get install hwinfo rfkill
connmanctl technologies
hwinfo --network
rfkill list

and post the results here.

Thank you for your answer.
Unfortunately, my pi is not connected to internet. I have no wired connection at home, so i cannot install hwinfo and rfkill.
At least, here is the connmanctl technologies result :

  Name = Wired
  Type = ethernet
  Powered = False
  Tethering = False

And i only have that.

I see. You’re posting on this forum and were able to download an OSMC image, so there are possible workarounds. I can tell you how, if you want.

That said, the output from connmanctl technologies doesn’t show the presence of either wifi or bluetooth. Though I can’t be 100% sure, hwinfo and rfkill are likely simply to confirm that the problem is hardware related.

I am using my phone 4G connection on my computer. so I can download whatever the internet can give me from there and then put it to my pi through usb or sd.
so, what are those workarounds you’re talking about ?

A suggestion from @fzinken is to install a copy of Raspbian Lite (now officially called Raspberry Pi OS) Operating system images – Raspberry Pi

If the problem is still there, it is almost certainly a hardware defect.

I’ll try it, thank you.
just to be sure, once it is installed, where should I look ? I’m not used to linux os.

Raspberry Pi OS is now installed and running, but still no wireless connection.
connmanctl and hwinfo are not installed. rfkill list gave no result.

When you log onto to the pi userid, do you see a message saying something about wifi being disabled and you need to set the country code? I remember it occurring on my Pi3, which has built-in wifi, but it didn’t appear on my Pi1, which doesn’t have built-in wifi.

Nope, I don’t have this message.
On desktop after startup, I have on top right corner the network icon with two red cross on it. on hover it says “eth0: Link is down” and on right click, it says “No wireless interface found”
That sound pretty bad :confused:

Have you tried a different power supply? It could be that your current supply has degraded. That can cause odd problems.

How sure are you that this is a Pi3 and not a Pi2?

If it is 100% a Pi3 and WiFi is still not working with Raspbian then I can’t really see any other explanation than it’s broken.

1 Like

From top log

Machine model: Raspberry Pi 3 Model B Rev 1.2

1 Like

Just to be sure: Have you always used the same SD card or meanwhile tried another one?

long time without any news.
I tried two other different power sypply, one from my pi1, and another from my my phone. No success. I mean the OS start and seems to work correctly, but wi-fi is still dead.

I also used multiple SD card, all between 32GB and 8GB, same result everytime.

Well i guess this is it. Bye little pi3 T_T
Thank you all for your help anyway :slight_smile:

Neither of which are likely acceptable to use for a RPi 3. PSU’s for RPi one are usually lacking enough current capacity to work without issue on later models and phone chargers are almost always lacking in voltage regulation as that is not terribly critical to charging a battery.

Since this was also broken on the official Raspberry Pi OS I cannot see that it can really be anything other than just a broken board, depending on when you brought it you might be able to return it as faulty.

1 Like

A low-cost USB WiFi adapter should get you up and running again, so there’s no need to junk the Pi 3. If you want to use the Pi for OSMC, it might be safest to stay away from Realtek-based dongles.