Wireless settings lost every reboot (ARMv7, 1gb ram, OSMC 2017.06-1)

I recently got my hands on a new RPi and installed OSMC 2017.06-1 using the Windows based installer. I find that I have to reconfigure the wireless settings every time I boot the device, is there no way to make it keep the ssid / WPA2 key info through reboots? Please advise.

On boot the device shows the library entries for my assorted movies / tv shows, but when I go to the files list to play one it tells me the network is not connected. I have to go into the ‘My OSMC’ menu and configure the settings in the ‘Network’ panel every time.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Can you specify which log files you need to see? I can pastebin the logs easily enough.

Tip: paste-log (can be piped or you can pass a file as an argument) will give you a paste.osmc.tv link. We prefer these links because they don’t have ads and they expire after a period of time.



and thanks!!

You’ seem to be running an external WiFi adapter but haven’t disabled the Pi 3’s internal adapter.

If you want to use the external adapter add the line


to /boot/config.txt and then reboot.