Without providing diagnostic data in the form of logs, your argument doesn't help

All this from a user who appears to have never uploaded logs.

Don’t feed the troll. IMHO, I have given him enough chances to address the problem properly in a new thread or get some information from my remarks… Maybe @sam_nazarko himself can get through to him. Otherwise he’s beyond help :wink:

I think it is time for the ban hammer…

I think it is time for the ban hammer…

I think it isn’t the good answer.

Inside Kodi forum no log —> no problem.

Now the Intel promotion, maybe right today, maybe wrong tomorrow. I remember some Intel experiences.

Now AMLogic problems, it’s right. But a lot of people, not only Sam, search/found solutions, you can take a look in the Kodi Github

For me that is Opensource power, right sometime it’s need a time. But if everybody give, time, logs, money, try to be inside the community, its go forwards.

For @Joker1982 Joker1982 I don’t know, perhaps Intel marketing, but I think it’s more that he don’t understand Opensource.

Which scene? What’s the timestamp?

I’m not getting any buffering issues on my network (which is a bit convoluted and messy btw) and I’ve tested many many uhd rips.

I’m using an fstab mounted share and a usb ethernet adapter.

Tell me where the problem is in American Assassin and I’ll test it.

Just to add a bit of info, when I first got my Vero 4k I had problems, there is a section of JW2 I used to use to test so I could tweak my advancedsettings.xml. I think it’s the second chapter. I bought a usb adapter, even switched out an older switch for a new one. Now after all that AND some updates from the team everything plays back without any buffering.

Another thing, I had the SAME buffering issues on my Nvidia Shield, so a gigabit port wound’t necessary fix the situation. UHD playback is very demanding.

I kind of feel the need to comment a bit more here.

I do have my issues with the Vero 4k, 422 12bit at 24Hz not working is a bummer for me right now. It means it won’t work the way I want it to with my pj. I’ve ordered a HD Fury Linker to get around this. Now the way I view it, I’ve just spent £5000 on a new Epson pj and an OLED tv. The cost of the Linker (which will be handy for other devices too) is pretty easy to bear.

Currently there are also dropout on some UHD remuxes due to high bitrate atmos tracks. Less than ideal. However I’m sure this will get sorted out at some point. Either by the ffmpeg/kodi devs or by the Vero team. The Shield suffers from this too. As would a NUC.

The point is we are in a very very niche area here. UHD remux network playback. Its going to take time to iron out all the bugs and get things working perfectly. The Vero 4k already has enough positives to make it worth while for me. Auto res and auto colorspace switching being the big ones. The Shield can’t do this.

The point is being on the cutting edge will always mean you need to tweak and wait for problems to be resolved.

Other wise buy discs and a dedicated player like the oppo, problem solved.


Would be able to give me some timestamps where the problems are in American Assassin and Deepwater Horizon?

I’m honestly interested in trying to replicate the problem.

The best thing for you would be if someone else could check. That way you’ll know whether it’s a problem that could be fixed at your end.

What I don’t understand is, the fact that you say the issue of the 100Mbit Ethernet adapter can’t be solved, but it can and I bought my Vero 4K and Gigabit adapter at the same time. No issues at all and only costs €15 extra which is pretty cheap considering it totally beats the Shield and is way cheaper.

And the Vero only costed me €112, even with the 120 pound price it would have come to a €136 price. So no clue where you get the €150 from.

I actually used to see the kind of buffering problems the op is seeing. On very high bitrate UHDs.

I’d see kodis buffer occasionally drop to zero and the video would stutter before recovering. I’d also see the same with iperf. I’d get a pretty solid 180/190 Mbits/sec with my adapter running a test then every 30 secs or so it would drop to zero.

The drops have now disappeared and my connection is completely solid.

The more I think about the more I’m coming to the conclusion that it was one of my switches.

This was my setup (at least when it comes to the Vero 4k and NAS)

NAS —> TP-Link Switch —>(very very long cable) —> Netgear Switch ----> Vero4k

Since swapping out the Netgear switch for another TP-Link one (mainly because I needed to move to an 8 port one rather than the existing 5 port switch) the drops have gone.

I’m going to test American Assassin and Deepwater Horizon later but I’m pretty confident they’ll play fine, they have a similar overall bitrate to John Wick 2.

In terms of an official statement, you’re asking for confirmation of a fault. But we’re not sure at this point why you’re experiencing problems as we would need further information.

I’m happy to address any concerns you have however.

  • The 100Mbit Ethernet port should be adequate for 4K HDR content. I note that you say that BD rips are becoming more demanding; but there is a defined specification which limits this. With the next generation of Blu-ray Discs in several years time; we’ll likely need to review this.
  • Playback performance can vary significantly depending on how your network and system is configured. For example, there is a noticeable performance increase when using kernel (fstab) based mounts. Additionally, in most circumstances, NFS will outperform SMB, regardless of how it is mounted.
  • Sometimes we do find problems with some titles. A recent example would be John Wick 2 or Serenity which would freeze for a few seconds. This problem wasn’t caused by the bitrate of the file and wouldn’t have been remedied by adding a Gigabit Ethernet port. This has now been reported as fixed and will be included in the next update. These improvements will no doubt benefit other titles as well.
  • I note that you mention the Intel NUC, but this doesn’t do HDR. You would be doing yourself and others a disservice to suggest it as an alternative, simply because it has a Gigabit Ethernet port. As others have noted, if you insist on a Gigabit Ethernet connection, then you could add one by the way of USB.

To provide you with better advice, we’d need to know a few things, such as how your shares are mounted. It would also be good to know if titles freeze in the same place every time; as this would give us an opportunity to reproduce the problem locally and see if there’s something that needs fixing on our side.

As always I’m happy to take a call and discuss this with you if you would like. I’d like you to be able to use your Vero 4K to watch 4K HDR content as intended. I will also investigate the titles that you have mentioned as problematic and see if I can find issue with them.



Also, the process of re-encoding without losing HDR info isn’t very easy yet, and doesn’t work the same for every source disk. Once that happens, you will see fairly transparent re-encodes with much lower bitrates than the original disk.

So, we’re kind of stuck right now for a while, but soon there won’t be nearly as many issues, because those 80Mbit originals will look great at 30-50Mbit.

1 Like

So, you’ll replace the $130 Vero 4K with a $300-500 NUC because of 2-3 UHD movies you are having problems with.


Well, if it makes him happy… :rofl: Logic didn’t seem to be of relevance anyways.

1 Like

I could add here that I’m also aware those drops can happen on a network even when everything seems to be fine and well for solid GBit connections:

In my home setup, these drops are sometimes even noticable when copying bigger files between computers and shares using Windows: solid transfer rates for some time, then suddenly a drop to zero and resuming after a short period of time. These kinds of drops would certainly affect the playback of high-bitrate files on the Vero 4k (the drops sometimes last for 10-20sec). It hasn’t been an issue here until now as this network only feeds an RPi3 running OSMC and not my Vero 4k. So, highbitrate content is not played here… This is defintely something worth looking into, if there are dropout issues or buffers running low to the point of being empty every now and then. :+1:t2::slightly_smiling_face:

Especially if one experiences issues others don’t experience with the same source files and the same playback device (Vero 4k), these kinds of issues are worth looking into.

Over the last couple of months, there have been improvements to how the decoder requests data which means it’s less likely to under-run.

I also have a further improvement which I’ve sent to @grahamh to test out.


Some of that is the way Explorer reports the copy. Memory cache of the file before writing to disc will boost the apparent speed, then when the cache is being flushed, the transfer rate drops to nothing, because cache doesn’t use good round robin, but instead gets fully flushed before more data comes from the network.

You can really see this on 10Gbit networks, where the copy speed starts at 600-800MB/sec if the data is in cache on the source, then drops to 300-400MB/sec, then drops to 50-100MB/sec once the destination has to flush to disk.

A bit outside my expertise but isn’t this what QOS is supposed to sort out?

There’s no QOS unless you have competition for the network from packets with different priorities. If all you do is copy files using Explorer, everything is the same QOS value, even if you are running multiple copies at the same time.

Well I’ve given both American Assassin and Deepwater Horizon a looksie. Not watched them properly but I’ve spend a chunk of time looking for high bitrate scenes and I have zero problems with buffering. I can quit easily chapter skip and skip anywhere in the file, playing over the network without problem.

I’ve checked out as much as I can can tonight and I’m having no problems playing them.

Like I said before this is with a usb Ethernet adapter and an fstab mounted nfs share. Hardwired, no wifi.

Will watch them both properly this week once my Linker turns up.

But all I can say right now is that any buffering problems are highly likely to be network related and not a problem with the Vero 4k.