Without providing diagnostic data in the form of logs, your argument doesn't help

No, it‘s no infrastructure issue!

As in several posts clearly readable is there an issue with vero 4k and several movies because of performance issues from the vero 4k side!

Friendly speaking the vero 4k is promoted for 4k hdr! That mesns in general all movies should work! Sam explained there were no need for a gigbit ethernet port or it could have faced issues. But open speaking right now I get more and mote the feeling the ethernet port is the only issue right now, but an issue which can‘t be solved. There for I request an official statement! I‘m testing like many others till December and really no one could confirm a configuration with network storage and possibility to play all available 4k hdr movies without issues!
I‘m not asking for the possibility to play 4k hdr test files with totally over the top bitrates! I only want to play all available 4k hdr movies from network storage which is a completely normal structure and not locally via usb! Then I could buy a big amount of cheap china boxes, which also cannplay this kind of stuff via usb! Pls vero 4k post an official statement for this issue! A clear one!

4k HDR will work in normal use (available 4K HDR Movies) via network share without buffering issues? Yes or no, and if yes what is the roadmap? When it should run? The release of the Vero was last year so it should be workable to place a clear statement on this matter…

I can understand being frustrated. But can you comment on how the rest of your system is configured? If one user like myself has no issues, then maybe the problem is not with the Vero itself? Surely something to consider. I’m happy to share further details on my set-up if that might help you.

First question you should answer for yourself and think about before being so loud here, please: When did the first UHD rips become avaliable (also for devs to adjust to the requirements of them)? And when did they become more available than just a few ones?
That didn’t happen when the box was introduced and has only happened over the last months… So, be patient when it comes to that matter, please. :wink:

The statement is, as you see above from others: The network port of the Vero is not a general problem! It’s working for many without problems (there’re probably more with no issues who don’t write on the forum than those having issues and bringing them up here). So, having said that, every setup and network environment is unique to a certain level and therefore there can be issues hard to find or solve, but it’s definitely not a general issue with the Vero 4k’s network port OR the Vero 4k in general.

We can understand your frustration, but please be patient and trust the devs to fix issues and also trust others, who are on this forum, helping others, without compensation during their free time, to help you find a way to work around your problems… :slightly_smiling_face:

The main issue is, that for sure there‘s nit one setup which can play all movies without buffering issues. Not the main general bitrate is the issuey The issue is based in the cache/buffer. In case of peaks in some movies the cache goes totally down and is not realoding. Also I posted my setup in another post. And already in December were enough movies availableb with this issue. I only post this clear words because always it‘s mentioned that there‘s no issue from official side. but there is! Right now a lot of people checking to buy a vero 4k for 4k use because on official side the player is promoted to play 4k hdr via networkshares! I think this people should gave the chance to know this issue, so that they can wait or can buy an intel nuc which only costs 100 bucks on top…

And only to clearifiy, in my setup I have running fast wd nas disks and also have dual gigabit ethernet installed on the server side. server is running with openmediavault. And I also can confirm, same movies are running without issues on other players over network!!! Also several other users can confirm this! And that‘s why I‘m annoyed. This problem need to be official… And when there‘s no solution for this, it should be stated official and it is OK…

As it’s not working for you the way you’d expect, means there is an issue, yes. Nobody stated the opposite or implied that your issue is no issue. The point of this whole thread is to work this out for everyone who has issues related to 4k UHD playback… But it seems that finding solutions for everyone isn’t that trivial and not all problems might be the same problems.

The Vero 4k can do that, but it’s not perfect yet (when it comes to newer UHD rips which are sometimes pretty demanding and therefore some adjustments must be made). Yes. Again, that’s what this thread is for. To work on any issues that still exist. The devs only have so much time, so not every fix is ready as fast as one would wish for (but there’s ultimately always been one before!). Please refrain from generalizing your issue and the ones being worked on here as something every potential buyer should know about as a flaw in the product itself… The Vero 4k already offers more functionality than any other box and it’s working for arguably more users than for those who have problems. And the devs are working hard on resolving all issues for all users.

Believe me, I’ve been at that point, too. Being frustrated and thinking that my issue wasn’t taken seriously enough. But devs were always friendly, helpful and delivered on every promise so far. :slightly_smiling_face:

If you feel that your issue is not properly addressed here, please open up a new thread describing you issue in detail again and leaving all the information relevant (logs, setup hardware information, etc.). This thread is for testing a solution and not so much to discuss this in such a length.

zHey sorry…

I‘m not generalising. For sure this movies won‘t work over networkshare at no one without buffering. From my side I‘ll switch to an intel nuc with kaby lake the next weeks, in case there won‘t come a fix which is promoted till December! Same as the patch for HDR (or the gui buttons for this). And also I can recommend interested buyers to wait 3 or 4 more weeks, if a fix can implemented or not. If not, they should take 100bucks more and buy an intel nuc…

Friendly advice: you are not posting in a way to actually encourage fellow community members to help you. It’s a bit like people who call help-desks to complain and then rant at the poor person who answers the phone. That’s not the way to influence people to the outcome you want.

1 Like

Honestly, Sam has never promised or advertised fixed dates for any fix to be ready. It’s a mere time frame or what he hopes to achieve. But some things turn out trickier than expected. As said before, UHD rips are fairly new and the testing and adjusting has to be done after the release of the product with the help of us users. We have to be patient for that, but we’ll get a better result than with any other product, if we are. That I trust in.

Please refrain from negative advertising for others based on your issue. Many are happy here and the comparison of an Intel NUC and the Vero 4k is not a very fair one: it’s more expensive, cannot hardware decode as well as the Vero and doesn’t have dedicated software support by a group of devs and a forum like this. Advising people to spend 100 bucks more on something completely different… I don’t know :wink:

Again: Please open up a new thread, if you feel that your issue is not properly addressed and might even be of a different origin than what this thread is addressing.

It‘s not only my issue…

And this issue is placed in several posts, but still the devs are writing phrases like no usb gigabit adapter is required for playing a 4k movie! yes… some movies will run without issues but anyhow there are coming more and more movies which won‘t run in case there won‘t be a fix on this issue! For sure it‘s not an setup issue. It‘s clearly a performance issue of the Vero 4K. And the issue is based on the ethernet port! When you play same files via usb they‘ll play without issues. And same movies you can test at each setup with network storage and they‘m face an issue!

The main problem is, that new released movies going up in brandwitdth which also will mean there will be more and more movies with this buffering issue! There need to be programmed a workaround for the buffer! And also they need to find a solution for the HDR issue. Tje subsampling to 422 is not working correct! And open speaking this is a basic feature of each available 4k device. At the most of actual several projectors you won‘t be able to play hdr without buying a hdfury linker which also costs around 150€. when you take this 150€ and the vero 4k you can easily buy an intel nuc…

Honestly, it doesn’t really sound like you actually want this resolved or are believing that it will be, but you’re just interested in letting off steam.

The devs are working on a solution, but ranting on about it won’t speed things up. The bandwidth of standardised UHD video formats are not exceeding the bandwidth of a fast ethernet port. So, technically the port of the Vero 4k is quite sufficient. That is a fact and therefore the reply to that claim has been the same will be the same.
It’s known and obvious (by the mere existence of this thread) that there has to be some tweaking for higher bitrate files. But this is not a thread where talking about it is done, but as you see in the headline, it’s a test thread. So, devs are offering test builds for us to test and give feedback. What other proof do you need of a fix being worked on? :rofl:

Be sure that, as soon as these playback issues are resolved, there will probably be another testing thread for some HDR playback and conversion adjustments. The issues are known to Sam and he’ll work on all of them. But for him, every day only has 24hrs, too.

I’ll leave it at this and hope for you to be patient and let the devs do their magic… And keep in mind, the more the devs have to reply to double complaints on the forum, the less they have time for actual fixing :wink:

Have a nice Sunday! :sunny:

Can I suggest that we all stop replying to this thread now. It’s beginning to feel like trolling. @Joker1982 seems convinced that playback issues are due to the network port. I have found the recent UHD releases of The Dark Knight Rises and Dunkirk to have high sustained bit rate, yet both of these titles play fine for me, even when sourced from my old (and now guinea pig) server, a Synology DS214+ (running a 1.33 GHz Marvell CPU).

1 Like

Dunkirk and Dark Knight also play fine…

Try American Assasin, Boston, deepwater horizon etc… in all this movies you‘ll face buffering. cache will run empty and won‘t reload fast enough… I‘m not a troll… You‘re fanboys because you won‘t recognize the truth…

All this from a user who appears to have never uploaded logs.

Don’t feed the troll. IMHO, I have given him enough chances to address the problem properly in a new thread or get some information from my remarks… Maybe @sam_nazarko himself can get through to him. Otherwise he’s beyond help :wink:

I think it is time for the ban hammer…

I think it is time for the ban hammer…

I think it isn’t the good answer.

Inside Kodi forum no log —> no problem.

Now the Intel promotion, maybe right today, maybe wrong tomorrow. I remember some Intel experiences.

Now AMLogic problems, it’s right. But a lot of people, not only Sam, search/found solutions, you can take a look in the Kodi Github

For me that is Opensource power, right sometime it’s need a time. But if everybody give, time, logs, money, try to be inside the community, its go forwards.

For @Joker1982 Joker1982 I don’t know, perhaps Intel marketing, but I think it’s more that he don’t understand Opensource.

Which scene? What’s the timestamp?

I’m not getting any buffering issues on my network (which is a bit convoluted and messy btw) and I’ve tested many many uhd rips.

I’m using an fstab mounted share and a usb ethernet adapter.

Tell me where the problem is in American Assassin and I’ll test it.

Just to add a bit of info, when I first got my Vero 4k I had problems, there is a section of JW2 I used to use to test so I could tweak my advancedsettings.xml. I think it’s the second chapter. I bought a usb adapter, even switched out an older switch for a new one. Now after all that AND some updates from the team everything plays back without any buffering.

Another thing, I had the SAME buffering issues on my Nvidia Shield, so a gigabit port wound’t necessary fix the situation. UHD playback is very demanding.

I kind of feel the need to comment a bit more here.

I do have my issues with the Vero 4k, 422 12bit at 24Hz not working is a bummer for me right now. It means it won’t work the way I want it to with my pj. I’ve ordered a HD Fury Linker to get around this. Now the way I view it, I’ve just spent £5000 on a new Epson pj and an OLED tv. The cost of the Linker (which will be handy for other devices too) is pretty easy to bear.

Currently there are also dropout on some UHD remuxes due to high bitrate atmos tracks. Less than ideal. However I’m sure this will get sorted out at some point. Either by the ffmpeg/kodi devs or by the Vero team. The Shield suffers from this too. As would a NUC.

The point is we are in a very very niche area here. UHD remux network playback. Its going to take time to iron out all the bugs and get things working perfectly. The Vero 4k already has enough positives to make it worth while for me. Auto res and auto colorspace switching being the big ones. The Shield can’t do this.

The point is being on the cutting edge will always mean you need to tweak and wait for problems to be resolved.

Other wise buy discs and a dedicated player like the oppo, problem solved.


Would be able to give me some timestamps where the problems are in American Assassin and Deepwater Horizon?

I’m honestly interested in trying to replicate the problem.

The best thing for you would be if someone else could check. That way you’ll know whether it’s a problem that could be fixed at your end.

What I don’t understand is, the fact that you say the issue of the 100Mbit Ethernet adapter can’t be solved, but it can and I bought my Vero 4K and Gigabit adapter at the same time. No issues at all and only costs €15 extra which is pretty cheap considering it totally beats the Shield and is way cheaper.

And the Vero only costed me €112, even with the 120 pound price it would have come to a €136 price. So no clue where you get the €150 from.