Wrong architecture?

Running a Vero 4k with Domoticz (home automation) on top.
All good but for some reason not sure if it’s Domoticz or OSMC but it installs the wrong architecture version.

So when I run curl -sSL install.domoticz.com | sudo bash as per http://www.domoticz.com/downloads/ it detects the aarch64 version and installs this, install runs fine but then never works, I then worked out to take the armv7l and extract it over the top for it then run the executable etc.

Is this a problem with OSMC or Domoticz?

The script is probably checking the architecture from uname -a; which isn’t correct.

Is uname -a fixable?

You’ve had the answer here: Whats it 'like'?

I knew I’d asked this before but couldn’t find it.
Anyway that’s not a fix but a workaround, from what I can make out I need to download the script and modify it, I’m by no means a linux guru and no different really than me just downloading the correct version and extracting it over the top now.

Why is uname -a wrong?

Because the kernel is arm64 and the userland is armhf.

Hey @CalzorSuzay ,

Would you be able to quickly lay out how you fixed this? I can’t seem to get this right.

I downloaded the armv7l.tgz, extracted it, and replaced the domoticz file in /home/osmc/domoticz with the domoticz file in the .tgz.
Now I get the error message: “illegal instruction” :expressionless:

If it’s not too difficult to explain it would be much appreciated!

I don’t use Domoticz anymore but moved onto Home Assistant in a separate box.

From memory though I think I replaced the whole directory (once extracted) not just a single file, so the complete contents of the domoticz download “domoticz_linux_armv7l.tgz”

I made sure I had a backup of my database and any scripts etc.

Got fed up with Domoticz or the lack of help, made my way to HA and there’s way more you can do with it, along with the help in the forums etc.

1 Like

Hey @CalzorSuzay,
I just wanted to say THANKS for your response! I got it to work thanks to your instruction. Much appreciated.

1 Like