Wrong libc6 version after update prevents raspotify install

I have just updated my RPi 4 to the latest September 22 version. All good except for one thing. I wanted to install the latest version of raspotify, as I had been stuck on an older one for a while (as raspotify needs Bullseye versions of key packages). However their installer says:

Unmet minimum required package version(s):
libc6 >= 2.31 is required but 2.28-110.12.31-113 is installed.
Please make sure you are running a compatible armhf (ARMv7), arm64, or amd64 Debian based OS.

Which is odd because if I run apt list libc6 I get:

libc6/unknown 2.31-113 arm64 [residual-config]
libc6/unknown,now 2.31-113 armhf [installed]

So it looks like I already have a more recent version? I’m not sure I understand the issue, or how to fix it. Here are my logs. Any suggestions please?


We have patched libc6 so that we can support Google’s publicly released Widevine libraries and support Kodi add-ons that depend on it, such as Amazon Prime and Netflix. You should be able to patch the script to handle this exception.



Thank you for clarifying. It works indeed.
For anybody coming here and as little tech-savvy as me, I downloaded install.sh and in line 8, replaced the libc version by 2.28.