X265 video is choppy


I’m using my vero4K since almost a year now and I’m very happy of it and osmc installed on (thank you !)

A few days ago, I tried to play a MP4/HEVC file and the result on screen was impossible to watch : the video was very choppy/stuttered (not sure how to describe this in english). Audio was just fine.

I thought it was the file itself or the NAS (protocol used is SMB) it was stored on or the network between NAS and Vero (which is Gigabit ethernet), but it played just fine from same place and on wifi on my phone and also on a windows computer on gigabit too.

I tried to play other MP4/HEVC file and couldn’t reproduce the issue, it only happened with this one but can’t find why.

here is the mediainfo output of the file : https://paste.osmc.tv/unatomerub.coffee

and here is the logs : https://paste.osmc.tv/sujiwubawi.xml
(Note: I have sanitized all network path by a generic “smb://…” and original filename by “filename.1080p.BluRay.x265”)

I’m not sure to have checked everything, please let me know if something else is needed to help you helping me :slight_smile:


I would check for updates at the terminal to see if you have the same issue as was found in this thread…

And if that isn’t the problem I would suggest to provide a full log set instead of just the Kodi log.

Thanks to point me to this thread.

I did the sudo apt update and sudo apt dist-upgrade successfully, but no change on the behavior while playing the file (I searched for updates from myOSMC addon, but no updates was found).

I’ll look on how to get all logs and reply back

1 Like

Thank you for the link for log upload, here is the full log this time (I mean, I think this time, everything is in):
(Note: I have again sanitized all network paths, addresses and mac addresses by a generic one)