XBox Media Remote

Hi,

I have problems installing my Xbox media remote. I bought it recently and read it is compatible with OSMC.

I connected an IR receiver to received the signals and checked the wiring several times. Also I tried to blacklist xpad but it didn’t help. I configured also the Xbox 360 in the remotes setup on the OSMC but it didn’t help either. The pi (raspberry pi 2 model B) does not react on any of the inputs from the remote. Does somebody has an idea? Is this remote supported at all?

Thanks in advance!
OldWarrior

Did you try rebooting since connecting the receiver?

I’m not sure where you read the xbox one media remote was supported by OSMC - the Xbox 360 media remote definitely is (at least when used with a GPIO based IR receiver) however I have not seen anyone mention the Xbox one media remote either to say that it does work or that it doesn’t.

When you say you “connected an IR receiver”, what kind of receiver did you connect exactly ? Is it a USB receiver or a GPIO receiver ?

If it’s a USB receiver did it come with the xbox one remote or is it one you got elsewhere ? USB receivers don’t tend to work with anything other than the remote they come with.

If it’s a GPIO receiver make sure you choose “enable LIRC GPIO support” In Pi Config->Hardware support in OSMC settings and then reboot, otherwise the GPIO IR receiver won’t be working.

After that try the Xbox 360 profile to see if it works. If it doesn’t or not all the buttons are working properly it is possible to learn nearly any IR remote using a GPIO receiver but we’ll cross that bridge if we need to.

1 Like

Thanks for your answer. I checked the settings in “enable LIRC GPIO support” and they are activated.
Sorry for not beeing specific I installed a GPIO infrared receiver. I tried both profiles for Xbox remotes
neither is working. Also I exchanged the cables and tried with another spare module for the receiver but
no keys are recognized of the remote. Do you have any idea?

Try downloading this file to to a file called xbox-one.lircd in /home/osmc

http://paste.osmc.io/raw/pizinacesu

Then in the remotes section choose browse to browse to this file.

I have not tested it, (I don’t have an xbox-one remote) it’s a lircd.conf file for the xbox one remote that I’ve found online and edited the key mappings for OSMC - it will probably work but some of the button mappings may not be correct - if it works please let me know if you think the buttons are all doing what they should be, if not we can attempt to correct them.

2 Likes

Just tried it and works perfectly. Thank you very much for the help!

OldWarrior

1 Like

Thanks for confirming it works!

I’ve added it to our built in library of remote configs which will be made available to all users in a future update.

https://github.com/samnazarko/osmc/commit/416929f