XBox One S Controller Support


I have a setup made of a Rpi3, OSMC and Moonlight/Luna for Game streaming from my PC to my TV. I tried yesterday to pair an XBox One S Controller, it didn’t work. I then disabled bluetooth ertm on the Rpi and the pairing worked successful.
Unfortunately, two buttons (select and Home) aren’t working. Getting this sorted would be pretty cool, as this controller is very popular.

Is this already in progress, or am I bringing a new issue here?


Enable debug logging, monitor the log file tail -f .kodi/temp/kodi.log and check if you get an entry when you press the buttons! If you don’t get an entry when you press them nothing you can do about it. If you get an entry when you press them you can use the Keymap Addon to assign a function to them.

Thanks, will look into this workaround.
Hoping someone more knowledgeable about Bluetooth might be able to offer a clean fix for the next release.

This is not related to a Bluetooth problem but key mappings

I doubt that there will be a fix as first quite a specific topic you have there and secondly question is if it is a bug or just a missing configuration

This is not related to a Bluetooth problem but key mappings

I’m not sure Bluetooth is entirely out of the equation yet, but once again I’m not very familiar with this protocol.

The controller can pair, but once at the binding screen, all buttons but two work.
My understanding of the binding tool is that it waits for an input and binds it to the key being displayed. As pressing “Back” and “Home” doesn’t cause any reaction, I’m wondering if the binding tool actually gets an input.

The other option is that the binding tools waits for a specific range of possible inputs instead of listening to everything, and maybe these 2 buttons are somehow out of range.

To find this out enable debugging and watch the log file as I indicated above.
If no key press is transmitted not much you can do about it.