Yamaha AVR not recognizing resolution set by VideoPlayer

#1

Hello.

I am new to the OSMC community, and have recently upgraded to a setup consisting of:
OSMC 4k+
Yamaha RX-V685 AVR
Samsung UE75 RU7105

The 1920x1080x60 GUI is working fine, so are 1920x1080x24 videos (also detected as 24p on the TV).
The problem arises whenever I try playing 4k movies. It seems like the AVR is not able to negotiate(?) the resolution with OSMC/Kodi (the sound also disappears).

I did get this working by plugging the same HDMI-cable that usually goes from AVR to TV directly from OSMC to TV, and then plug it back in to the receiver after. But after a reboot of OSMC the same problem appears.

Logs can be found here: http://paste.osmc.tv/lefewahego
This is after trying to play a 4k movie (that was previously working with the “trick” I did).

The HDMI-cable between OSMC and AVR is the original one that followed the OSMC, while the HDMI-cable between AVR and TV is of an older (and probably cheaper) model. So this cable has been my main suspect, and I will try replacing it as soon as I get my hands on one, but it seems a bit odd that the very same cable works fine if I plug it directly between OSMC and TV?

“Adjust display refresh rate” is set to “On start/stop”, and seems to be working, just not for 4k.

#2

That log shows the information for the TV. It would probably be more helpful if you plugged it into the AVR, rebooted the Vero, and then uploaded logs again.

#3

This is a log with the HDMI connected to the AVR. There is no direct connection between OSMC and TV (in this log).

EDIT: In the AVR I have “Video Mode: Direct” enabled.

#5

My Yamaha (RX-660) has a setting Mode1 or Mode2. I don’t recall of the top of my head which mode is needed for 4K, but the default setting did not support 4K. Check your manual for the correct mode (and how to switch it).

#7

Yes, what you’re referring to is Mode 1.

This is already set (it was default).

#8

And you do notice that Note that you need to use a premium High Speed cable :grin:

Try a better cable than your cheap cable and see if that helps.

#9

Haha, yeah. That’s also why the cable is my main suspect. It doesn’t say “Premium” on the cable, but it does have Ethernet. I’ll try to get hold of one tomorrow to confirm. I was just a bit concerned the problem might be somewhere else, as a direct connection between TV and OSMC works.

#10

It may be that the Yamaha is more sensitive to the cable. A good premium cable isn’t that expensive, so it’s worth a try.

#13

You can also try swap cables, just as a test. so Vero provided cable between AVR and TV and current cable from to Vero and AVR. I’ve had same issues earlier with my AVR and Vero cable.

Cause it’s seems that your current cable is able to work between Vero and TV, so that will pass the signals needed. So it could be the OSMC cable… just check it out.

#16

I bought new HDMI-cables today. Switched out both the one between AVR and TV as well as AVR and OSMC. Everything is working as it should now.

Sorry for “polluting” the forum with what turned out to be an easy fix, and thanks for all the answers!

2 Likes
#17

No pollution - this could help someone else :slight_smile: