Yatse and OSMC (2017-12.1) Local Streaming

Hi!

I can’t get yatse to stream to my smartphone while connecting to my rpi 3.

Tried a lot of different tutorials and already read the faq von yatse, but it’s always the same error message. I CAN controll osmc with the yatse remote, but I get a 401 error when downloading a file (which is on an external drive) to the smartphone and a permission denied error message when streaming to the smartphone.

Here is what I already tried:

(1)

  • Installing Samba inside the osmc app store
  • adding the external hdd to the smb.conf (copyied the osmc share and edited the path)
  • restarted samba

(2)

  • installing Samba inside the osmc app store
  • adding the external hdd to the smb-shares.conf (copyied the osmc share and edited the path)
  • restarted samba

(3)

  • installing Samba with sudo apt-get
  • adding the external hdd like in (1) and (2)
  • restarted samba

… it’s always the same problem at the end. Is there a tutorial for a fresh osmc install on the rpi. I already deleted my Pi 5 times now and it’s getting annoying now.

Hope you guys can help me. It would be great if I can get this work for once and then never ever having to deal with it again.

Thx

I’m using Yatse and stream plugin, it works ok with MX Player pro(free might work?).
Quite sure the stream is HTTP-based so samba shouldn’t matter.

regards
/L

Since I already bought yatse pro I would like to get it work. MX Player isn’t going to work for me since I don’t want to buy the pro version and the free one has ads in it.

Ok - anyway you need a player on the phone that can handle streams.

Regards
/L

As @El_Grincho wrote not related to samba as the kodi/yatse streaming is working via http.
For Music you should be able to play it via yatese directly. For Video you need a player to handle the stream. If you don’t want to buy the Pro Version of MX (a really great player) you also can install VLC which comes without ads.

I use Yatse (paid for Unlocker) and Yatse plays video just fine via VLC player. Flawless.

Yatse is NOT a videoplayer so you will need VLC (free).

First I’d like to thank you for the bad rating about your issue :slight_smile:

It seems contacting me by one of the twenty available ways was less interesting than the bad rating and posting here. Well why not :wink:

The FAQ is very clear about your very well known issue https://yatse.tv/redmine/projects/yatse/knowledgebase/articles/6 (And have some big bold part also explaining how to contact support if you do not understand that FAQ).

Anyway your issue is https://yatse.tv/redmine/projects/yatse/knowledgebase/articles/6#Missing-or-bad-sources
As you can see error 401 :wink:

All you need to do is add a correct source inside Kodi to the auto mounted folder. Since you did not contact support with logs I can’t tell you the exact path since it’s specific to every users.

It was reported multiple times to Kodi devs but maybe OSMC can do something specific in their release.

Automounted drives on linux are visible inside Kodi but are not added as a valid source so are not visible / accessible from Remotes / JSON.

3 Likes

@Tolriq thanks for commenting. While I know (and find this understandable) that only files are shown that are added as sources I wonder how that could relate to the 401 error. Because when the file is not added as source he would not be able to choose it in Yatse to stream it.

@Tolriq I changed the rating from 5 to 2 stars because it simply does not work. The other replys in this thread mentioned, that I need a second video player app to stream the content to my mobilphone, which is not clear at first inside the yatse pro app. Some tutorials are saying you have to install samba, others say it’s not a samba problem it’s a http problem.

The way I mount my drives in Kodi is by simple setting up the content type of the HDD and then scanning for files. I have not found a way to change the SMB oder smb adress like mentioned in the yatse faqs. OSMC samba does not support automounted hdds in the smb.conf because it seems to crash some of the drives.

I am simply clueless how to get this working. I haven’t tried the dummy source but I will give it a try.

If it’s going to work, I will change my google rating again, but so far it’s not working for me and many others.

Thanks for the help.

Install VLC and all your problems should be gone.
While you still need to ensure to have proper access to the files from OSMC user

401 error is access denied because a source is not made to a target with allowRemoteAccess
I kinda know since well I added that code to Kodi https://github.com/xbmc/xbmc/pull/2764

On linux Kodi auto scrape and add to library auto mounted drives but they are not belonging to a source so no access.

User can see the media via the library.

@kaykasus and at no time you thought you should contact support for help ?
Your issue is 100% Kodi side bug and configuration. All clearly explained and detailed in the FAQ. Not related to a player or anything.
And yes the dummy source is 100% the solution.

My real only question is really why not contacting support when I put hundreds of messages about useless bad ratings for support? I’m pretty sure you did not receive my answer there.
So please explain me why not contact support?

On OSMC my automounts are not scraped and added to my sources automatically

I did not contact support because I already knew you have to look at my log files, which were deleted at that time because I crashed the system (spent days/weeks to get the system running perfectly) with the different changes by changing inside samba, sources and the kodi settings. I am currently trying the dummy solution.

And I am and was just disappointed because the pro version does not mention the different things you have to do to get it running. If I knew before it’s not that easy I would not have bought the pro version and just gave you a donation for the free app.

Don’t be upset because I changed the rating. I am not rating you as a person, I am just rating my userexperience with the pro app as a noob.

@fzinken yes they are visible in interface and you can set a content type and scrape even if they are not proper sources.

@kaykasus bad rating instead of contacting support have no purpose. You have an issue you contact support. Why bad rate and ask here ? For the duration of writing your comment you’d have had help already…

And all works correctly on the majority of the cases. Not my fault if Kodi have bugs and issue. I do document all those bugs and propose the solutions for that.
Again all on Kodi side…
And as written everywhere I do provide instant support on 20 different ways specially for noobs.
I just can’t understand any possible reason to bad rate and write things like “Wasted money for me now.” when you did not even tried to contact support.
Support that is clearly explained in all the FAQ that will help you …

“The manual and faqs are not helping much” → Well they does cover exactly your case with the exact solution.
“There should be a detailed manual to get this running for all major kodi releases (osmc, kodi, xbmc …)” → There is even with videos :wink:

@Tolriq I have not seen the videos. Are they posted on the faq side?

It got it running with the dummy solution now. And I already changed the rating again.

As I said: from first sight as a customer, you should mention inside the freeware app that people have to tweek around to get it running. Since it is easy to get the remote running
I was in the belief (and I guess many other users too) the streaming would work without changing things too.

Ok this is interesting. So it’s not “automatic” but if people use “set content” instead of “Add Source” which is possible on automounts which would add them to the library without adding them as source.
Seems quite a specific issue but maybe still @sam_nazarko or @dbmandrake can think about if we want to make a hint on the automounts to avoid that.

The streaming does work without changing anything 95% of the time.
And FAQ explains clearly what to do for the missing 5% (Missing percents caused by Kodi bugs or weird decisions :wink: )
And Yatse identify the issue and clearly tells you to read the FAQ telling you access denied so you know what part of the FAQ concerns you.

And what I do for sure is writing hundreds of messages everywhere about how to contact support and the fact that bad rating for issue is useless, and yet you bad rated instead of contacting support.
Do you really think you’d have seen a line somewhere that says in 5% of the case you’ll need to configure Kodi correctly since you missed all those other messages ?

And as you can see your issue would have been 10 sec fix :wink: All that time lost trying things as you said instead of a simple mail. (And you can see support even on Sunday on a random forum where I had to create an account just for you…)

You have to configure Kodi to remote control it Yatse offers videos to help. It the same here you have Kodi issue Yatse offers help to configure it.

I can’t put warnings for the hundreds of Kodi bugs and workaround, it’s the same when I write supported media for streaming.
I can’t list the thousands of UPnP devices in the world and each codecs each supports.

Videos are in the normal Wiki.

@Tolriq

Well thanks for the help. There are always people complaining about apps or features because they can’t get it running or it’s to difficult for them, but as a publisher (I know it’s not my business) you should be more chill about those messages and ratings and not reply with rude comments as you did on some of those 1* ratings. But that’s just my 2 cents.

You are doing great work with the app and I know it’s hard to keep it running.

Well you may want to read https://yatse.tv/PSC :wink: Because I do not have not have a choice on those comments to try to help them more.

And you are actually the proof of the issue, despite all the messages everywhere you did chose to bad rate, did not get my instant answer on Play Store and lost time trying to solve and post here instead of doing the only normal thing to do :slight_smile:

So yes some people who do not read everything will make false assumptions but in the end i try to help the most I can it have a cost, but the benefits are superior until now and I doubt this changes as it’s like that since many many many years.

@fzinken @Tolriq Re playing auto mounted drives; The way I solve that is by adding a source that’s a shortcut to /media/ and name it “USB” where I then find automounted drives - works good enough for me.

Regards
Leif

1 Like