YouTube Add-on issues

So, I installed the YouTube add-on and got it set up and everything.

At first most videos would play fine, while some would simply load upon selection and then nothing.
Today, no videos will play anymore. Either they load for a while and then nothing or an error “failed to play item, check log file” is displayed.

Any chance someone can glance over my logs?

Make sure the addon version installed is 6.3.1 and clear function cache in addon settings

If that doesn’t work you can update to the latest alpha build that you can download here

And install via zip

Also remember to clear function cache in YouTube addon settings after install

Just tried those options, but nothing has changed.
The alpha version still has the same issues as the older version. Tried clearing all the other caches as well, but didn’t help either.

I’m sorry to hear that I hope someone else can help you! In most cases issues appear when youtube changes something in their back-end and those issues are fixed by the developer updating his addon.

I had a similar issue.
Most files played without issue, but a few simply failed.
Resolved by enabling MPEG-DASH option.

Not succeeded in finding any explanations as to why this might have worked - changes in YouTube back-end I guess.

Oh yes of course I didn’t even think of that. I thought youtube in 2019 doesen’t work at all without enabling Dash and configuring it.

Oh that sounds promising.

I enabled MPEG-DASH and it says proxy is required (see HTTP Server).
How do I set up that proxy? And what do I have to input under HTTP Server?

Look at this thread specially at my post at the end and the update at the end of the post.

I don’t think you have to enter anything under proxy you just need to install and enable it

I already had the settings like in that post. So I went backwards through that thread and started with manual stream selection, lower resolution and all. It worked at 144p just like for you. Then I bit by bit upped the settings like you until I arrived at the max and your last post.

Now I have exactly the same settings as the ones I started with that didn’t work, only now everything works.

Hell if I know why, but it worked. Thanks a lot!

1 Like