Youtube addon videos will only play in 720p

This is on a fresh OSMC install from the latest Raspberry Pi 4 image [2021.12-1].
I have tested both wired and wireless connections.

MPEG-DASH is enabled in the YouTube settings. I have tried to manually select 1080p video quality. I have also tried to set a high min bandwidth value (eg. 30000000) under inputstream adaptive settings.

InputStream Adaptive plugin seems to be installed and enabled (by default).

However, if I force the addon to prompt for video quality selection when choosing a video there is no DASH option (as I’ve read from other threads there should be). The highest quality option is only ever 720p.

NHK World addon (GitHub - sbroenne/ NHK World TV KODI Plug-in - watch live stream and on-demand programs) will stream in 1080p without issue. So the problem seems to be contained to the YouTube plugin.

I understand this is (probably) not directly an OSMC issue, but I thought I would try here first in case someone with the same set up has also run into this issue.



Must be config issue as it is working here
Screenshot from 2022-01-09 10-08-07
Screenshot from 2022-01-09 10-08-38

I was able to fix this by following the steps here: