YouTube Bad request

#1

Help I just installed OSMC on my raspberry pi 2 then I installed YouTube it downloaded without a problem but when I try to search something it say bad request

#2

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

1 Like
#3

Have a search on the Kodi Forum, I think I read youtube addon is broken currently

#4

That it is.
Very broken indeed.

#5

Hi I am currently running the latest version of OSM

The peripherals that are attached to the pi are HDMI, Wifi dongle, keyboard, and an micro sd card.

I tried installing the version 2015.12-4 but it still didn’t work

My pi is a Raspberry Pi 2 model b

Thank You

#6

Doesn’t matter what version of OSMC you are running… If the addon is broken, it will be broken on all versions. Google has changed their API key and until a working version of the YouTube addon is developed it will stay broken. Not an OSMC problem…

#7

Thread on the YouTube Plugin

http://forum.kodi.tv/showthread.php?tid=200735

Jump here to get zip’s
http://forum.kodi.tv/showthread.php?tid=200735&page=219

Github Maintained:

In particular to the fix is this file is what’s broken:

Broken addon
#8

I tried downloading an older version of YouTube and its works! :slight_smile:

I have another problem all the video addons are in different language. Anyone know how to change it to English?

#9

It is late and there are a bunch of links to read on this thread (thanks to the posters) YET it is late and these things will work themselves out–well I guess by greater minds than I will at least.

An odd thing I found, with rbp2 b+ & "VERSION_ID=“2016.02-1"” of OSMC, is that with Confluence skin at least, that I could us the “i” menu and the trailer button without fail… but the search says “BAD Request”–who is YouTube to judge my search for “Afroman Because I Got H—”?? hehe

Kidding, :stuck_out_tongue: but the APIs for the addon I assumed were same for both commands (text search and the “trailer” rectangle on “i” screen), but I leave it up to you pros & Kodi team :wink: Afroman will bumpbump in due time. So in my words the current state of the YouTube addon would be something like…

“It [YouTube addon] runs, but not on all four cylinders ATM”

Thanks to OSMC/Kodi team for keeping my lil’ SoC cruising. :sunglasses:

#10

Thanks! I have installed the zip file and now youtube searches work again… Do you know whether this version is included in any repository? It is to get the addon updated “automagically”.

Thanks :slight_smile:

#11

Latest there

1 Like
#12

It should auto update to the latest version, which for me at least worked last night

#13

That youtube master works perfect for me. As I understand it’s was fixed previous YT build which not support officially anymore.

#14

new repository available here : http://forum.kodi.tv/showthread.php?tid=267160

#15

Thanks for the link !
However I had a little issue at step 5 when entering the 3 keys after Kodi is shutdown.
I was still having “invalid credentials” response when trying to sign in after doing all the step by step procedure.
So first stop Kodi :

sudo systemctl stop mediacenter

add the 3 keys with nano or vi both in

“home/osmc/.kodi/addons/plugin.video.youtube/resources/settings.xml”

and

“/home/osmc/.kodi/userdata/addon_data/plugin.video.youtube/settings.xml”

start Kodi

sudo systemctl start mediacenter

Sign out from youtube and then sign-in again.