YouTube can't download on Kodi

Hi, I am a new user to Kodi/OSMC and installed the latest on my Raspberry Pi 3 B. I have a perfect internet connection and want to install YouTube on it but it says that the Kodi cannot connect to the repository. I then tried to use a flash drive (I tried the newest YouTube addon that was on the website) and it said that it was too old of a version (the version was from May 15, 2020.) Is there any other way to install it and is there a way that I can connect my Kodi to the repository without having to reinstall Kodi?

You shouldn’t have any issue connecting to the Kodi repo or installing any addon from zip file. Providing logs would be useful in understanding the causes of such issues.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot: