Youtube doesn't play some videos

Hi guys,

Yesterday i found out that YouTube plugin in my OSMC@RPi …doesnt play some videos, and the error message i get (in the log) is:

ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://]

Now - it’s a bit strange… for example on “Garand Thumb” (channel) some videos work, some don’t

But when I searched for a specific song (also covers/remake etc.) NONE WORKED - the song was: Wrong side of heaven by Five Finger Death Punch

Any clue? Anyone had/has the same issues?

BTW: All those songs work without any problem on my phone via NewPipe (also an unofficial plugin)

Thanks :slight_smile:

p.s Also I just found out that videos that worked approx. 2-3d ago (some of them) no longer work - and since i didn’t make any changes to my osmc config (as far as I recall there was no background “small” auto-update). So it must be smth that Google/YT changed - but I’m no expert, just my guess :confused:

This add-on comes from Kodi, and as such, their forum is the best place to seek out information regarding it. Unfortunately it is not uncommon for YouTube to make changes that then require updates and tweaks to get it working again. I would suggest checking the following thread for further assistance.

Well for clues it always help if you provide logs. Anyway I did a quick check and I get this error

                                      File "/home/osmc/.kodi/addons/script.module.requests/lib/requests/", line 390, in prepare_url
                                        raise InvalidURL("Invalid URL %r: No host supplied" % url)
                                    InvalidURL: Invalid URL u'http://': No host supplied

Which actually is the same error that has been reported here

But as @darwindesign wrote best to go on to the actuall Kodi Addon forum to look for help.
And as you can read there issue was reported and already fixed in the Alpha version


I finally succeeded to run Youtube add-on by loading this zip:

And I selected:

I’m still trying with zattoo. I tried to re-install OSMC (and zattoo too) from scratch with various OSMC version without success. As mentioned the problem comes probably from the zattoo add-on side.

I also tried a zip from ( without success. I had to register first with questions in german (thanks to google translate). The first attempt on my mac unzip it, so I compressed it again but got an invalid structure. I tried again from a linux machine without decompression. Then the zip load correctly but zattoo still doesn’t work.

1 Like

Maybe keep an eye on this issue report, could be similar.
Could try to change from HLS to Dash.

Than you guys for all your help! :slight_smile: You’re a bless.

I installed the patch/mod/addon that was linked and now everything works.

…suprisingly the “+matrix” version showed error (something about …no dependencies, as far as i recall), but the alpha version works just fine and I got my YT back.