YouTube framerate changing, triggers refresh change

Hi there,
I got a Vero 4k+ last week, it’s a lovely little box. Previously I was using my Windows PC with Kodi 18.9 which didn’t have this issue.
Kodi’s been set up to match refresh rate to the video, but when I try and play a YouTube video it will start in a framerate like 29.970, then after a few seconds switch to 30, triggering a second refresh rate change and blanking the screen a second time. Disabling InputStream stops this happening but I’d rather not if it can be fixed.
InputStream has had a few updates since the OSMC version, I don’t know if they’d help but I welcome any ideas! I’ve really tried everything I could think of.

Here’s my log

The explanation is pretty simple: If you’re playing VP9 streams, Kodi doesn’t know the exact framerate instantly when starting playback as this information is not stored in every frame header with VP9. It has to start playback with a good guess and then switches to the perfect framerate as soon as the information is available. We could technically wait for enough seconds of a stream to be scanned for the information, but we never know how long this might take - playback might be stalling for a long time until the info has been found.

As it’s the nature of the VP9 codec, there’s no elegant way around it. If you set inputstream to prefer H264 streams, this won’t happen, but you won’t get any playback above 1080p60 and definitely no HDR IIRC. But you might want to test this.

I actually tested H264 and it’s doing the same thing. But that does explain it. I take it my old Kodi version doesn’t use VP9 since I don’t think it was capable of HDR, so it’s using something else that worked fine. I guess I could do with a way of locking refresh rate for the add-on.

Thanks very much for the reply :slightly_smiling_face: