Youtube - Video's don't play with "content not available on this app" error

Hello there,
For a few days when trying to play YT videos on my Vero 4K box I’m getting this message that the content is not available on this app.
Read in another forum that it may be related to Google restricting usage of 3rd party apps.
Anybody here having this issue? Any suggestions for workarounds?
Thanks in advance.

1 Like

Yes. Often just trying again after a few seconds works. Note I have it set so I can choose the resolution.

I had already tried re-generating Youtube’s API key and nothing worked.
Now I changed the resolution settings and it’s working, thanks for the tip…
If pressing one button on the remote is the price to pay, so be it… Many thanks again!!!

1 Like

@anxdpanic might have some insight here. :slight_smile:

anxdpanic is aware but unable to do anything about it just at the moment. See the discussion at:

1 Like

I’ve been having the same issue for a week or so but followed the steps in the linked post to get it working again.

It’s only been a day but have not had any “content not available on this app” errors since.

We’re going to be in a cat and mouse game with google making the youtube addon look like an official approved google client.

The above only worked for some videos so I reverted to 6.8.26.alpha1-unofficial

Does older version work?

I started having problems with 6.8.25 hence the move to 6.8.26.